aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/prelink
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-06-28 20:36:11 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-29 14:36:01 +0100
commita0ba05596a704a006ee7b97392c20b871085b1e6 (patch)
tree9b353c85653d254e6931539e91de554cbf405fa7 /meta/recipes-devtools/prelink
parent8870ba9d261d3cacbe5d1219fdd95840c05ecf9e (diff)
downloadopenembedded-core-a0ba05596a704a006ee7b97392c20b871085b1e6.tar.gz
prelink_git.bb: Only block the postinst script when no image-prelink
If image-prelink is being used, the system will automatically prelink the target image. This avoids the need to run the postinst prelink script at first boot. However, if the user has not enabled image prelinking -- then we do enable the script to run on first boot. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-devtools/prelink')
-rw-r--r--meta/recipes-devtools/prelink/prelink_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-devtools/prelink/prelink_git.bb b/meta/recipes-devtools/prelink/prelink_git.bb
index b57c145353..c653d4d67a 100644
--- a/meta/recipes-devtools/prelink/prelink_git.bb
+++ b/meta/recipes-devtools/prelink/prelink_git.bb
@@ -10,7 +10,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
SRCREV = "ac461e73b17253a4da25c5aafeac7193b553156c"
PV = "1.0+git${SRCPV}"
-PR = "r3"
+PR = "r4"
#
# The cron script attempts to re-prelink the system daily -- on
@@ -58,11 +58,13 @@ do_install_append () {
install -m 0644 ${WORKDIR}/macros.prelink ${D}${sysconfdir}/rpm/macros.prelink
}
+# If we're using image-prelink, we want to skip this on the host side
+# but still do it if the package is installed on the target...
pkg_postinst_prelink() {
#!/bin/sh
if [ "x$D" != "x" ]; then
- exit 1
+ ${@base_contains('USER_CLASSES', 'image-prelink', 'exit 0', 'exit 1', d)}
fi
prelink -a