aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-09-07 15:05:02 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-08 00:31:38 +0100
commit66e55d3af7d7948869620ce24c06ba2bc705ae0a (patch)
tree689268c0e60ee88e655c1d17206136656ef18b0e /meta/recipes-devtools/python
parent808952bf6d2b7549b456293ead4728b4dbf0d89b (diff)
downloadopenembedded-core-66e55d3af7d7948869620ce24c06ba2bc705ae0a.tar.gz
python: recompile _sysconfigdata.py after modifying it
We sed this file after the .pyc has been generated, so re-compile the .pyc to ensure that it is up to date. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python_2.7.12.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python_2.7.12.bb b/meta/recipes-devtools/python/python_2.7.12.bb
index 3ee1e38b66..65b571719b 100644
--- a/meta/recipes-devtools/python/python_2.7.12.bb
+++ b/meta/recipes-devtools/python/python_2.7.12.bb
@@ -132,6 +132,7 @@ py_package_preprocess () {
sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile \
${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py
+ python -m py_compile ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py
}
require python-${PYTHON_MAJMIN}-manifest.inc