aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-09-08 00:18:20 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-08 09:56:23 +0100
commitae4db0bacb9d40489499f77905f26502f3bcaa19 (patch)
tree49de92c25109e8e32cac8bad04c085bdd8b81ec7 /meta/recipes-devtools/python
parentb23e51e6c961cf3f7e2aaf89648fecce78424c99 (diff)
downloadopenembedded-core-ae4db0bacb9d40489499f77905f26502f3bcaa19.tar.gz
python-native: add link for python2
Add link for python2 as some configuration tools search from a python2 and could find the host python instead of the python-native. Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-native_2.6.6.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.6.6.bb b/meta/recipes-devtools/python/python-native_2.6.6.bb
index 2b00d32364..e0a4fb36d9 100644
--- a/meta/recipes-devtools/python/python-native_2.6.6.bb
+++ b/meta/recipes-devtools/python/python-native_2.6.6.bb
@@ -1,6 +1,6 @@
require python.inc
DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
-PR = "${INC_PR}.3"
+PR = "${INC_PR}.4"
LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6"
@@ -42,4 +42,7 @@ do_install() {
for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
done
+
+ ln -sf python ${D}${bindir}/python2
+
}