summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-25 20:28:05 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-26 22:09:45 +0100
commit4cb9623933e3daeb754c06263167be61100f6c0a (patch)
treee9ecbb8a44891f248535db969c82884d965bf20a /meta/recipes-devtools/python
parentbcce0e7cef5768d5cfe58c356f6196af8ce03537 (diff)
downloadopenembedded-core-4cb9623933e3daeb754c06263167be61100f6c0a.tar.gz
python3-pluggy: upgrade 0.13.1 -> 1.0.0
* All ptests pass on qemux86-64 pluggy 1.0.0 (2021-08-25) Deprecations and Removals #116: Remove deprecated implprefix support. Decorate hook implementations using an instance of HookimplMarker instead. The deprecation was announced in release 0.7.0. #120: Remove the deprecated proc argument to call_historic. Use result_callback instead, which has the same behavior. The deprecation was announced in release 0.7.0. #265: Remove the _Result.result property. Use _Result.get_result() instead. Note that unlike result, get_result() raises the exception if the hook raised. The deprecation was announced in release 0.6.0. #267: Remove official support for Python 3.4. #272: Dropped support for Python 2. Continue to use pluggy 0.13.x for Python 2 support. #308: Remove official support for Python 3.5. #313: The internal pluggy.callers, pluggy.manager and pluggy.hooks are now explicitly marked private by a _ prefix (e.g. pluggy._callers). Only API exported by the top-level pluggy module is considered public. #59: Remove legacy __multicall__ recursive hook calling system. The deprecation was announced in release 0.5.0. Features #282: When registering a hookimpl which is declared as hookwrapper=True but whose function is not a generator function, a PluggyValidationError exception is now raised. Previously this problem would cause an error only later, when calling the hook. In the unlikely case that you have a hookwrapper that returns a generator instead of yielding directly, for example: def my_hook_real_implementation(arg): print("before") yield print("after") @hookimpl(hookwrapper=True) def my_hook(arg): return my_hook_implementation(arg) change it to use yield from instead: @hookimpl(hookwrapper=True) def my_hook(arg): yield from my_hook_implementation(arg) #309: Add official support for Python 3.9. Signed-off-by: Tim Orling <timothy.t.orling@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python3-pluggy_1.0.0.bb (renamed from meta/recipes-devtools/python/python3-pluggy_0.13.1.bb)3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb b/meta/recipes-devtools/python/python3-pluggy_1.0.0.bb
index 479c10fcdc..14a7ccb0b0 100644
--- a/meta/recipes-devtools/python/python3-pluggy_0.13.1.bb
+++ b/meta/recipes-devtools/python/python3-pluggy_1.0.0.bb
@@ -3,8 +3,7 @@ HOMEPAGE = "https://github.com/pytest-dev/pluggy"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2"
-SRC_URI[md5sum] = "7f610e28b8b34487336b585a3dfb803d"
-SRC_URI[sha256sum] = "15b2acde666561e1298d71b523007ed7364de07029219b604cf808bfa1c765b0"
+SRC_URI[sha256sum] = "4224373bacce55f955a878bf9cfa763c1e360858e330072059e10bad68531159"
DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
RDEPENDS:${PN} += "${PYTHON_PN}-importlib-metadata \