summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-06-08 11:13:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-11 23:55:36 +0100
commitac782fe535855ed87f87c2c9e1e584bf0181378a (patch)
tree837e5517686abef245bdf1d38080b38a6e251ce1 /meta/recipes-devtools/python
parent8dfdd329f0137cab8cab97e1d0c1181810fe5b32 (diff)
downloadopenembedded-core-ac782fe535855ed87f87c2c9e1e584bf0181378a.tar.gz
python-smartpm: change "already installed" warnings into info messages
It's possible to trigger "already installed" messages during normal usage if you explicitly install something in the image through IMAGE_INSTALL that has a dependency on some -dev packages and also have dev-pkgs in IMAGE_FEATURES. Since we now check the do_rootfs log for warnings, these are reported as warnings at the build system level. This situation should not trigger warnings, nor is it really cause for concern under any other circumstance if the user asks smart to install something that's already installed, so make it an info message rather than a warning. Fixes [YOCTO #7840]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python')
-rw-r--r--meta/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch54
-rw-r--r--meta/recipes-devtools/python/python-smartpm_1.4.1.bb1
2 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch b/meta/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch
new file mode 100644
index 0000000000..9055555cd0
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smartpm/smart-already-installed-message.patch
@@ -0,0 +1,54 @@
+From a74a9a9eb9d75964a0e978950e8b191d7a18d763 Mon Sep 17 00:00:00 2001
+From: Paul Eggleton <paul.eggleton@linux.intel.com>
+Date: Fri, 5 Jun 2015 17:07:16 +0100
+Subject: [PATCH] smart: change "is already installed" message from warning to
+ info
+
+This doesn't need to be a warning.
+
+Upstream-Status: Pending
+
+Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
+---
+ smart/commands/install.py | 4 ++--
+ smart/interfaces/text/interactive.py | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/smart/commands/install.py b/smart/commands/install.py
+index 6ef9682..80d456b 100644
+--- a/smart/commands/install.py
++++ b/smart/commands/install.py
+@@ -152,7 +152,7 @@ def main(ctrl, opts):
+ for obj in results:
+ for pkg in obj.packages:
+ if pkg.installed:
+- iface.warning(_("%s (for %s) is already installed")
++ iface.info(_("%s (for %s) is already installed")
+ % (pkg, arg))
+ installed = True
+ break
+@@ -184,7 +184,7 @@ def main(ctrl, opts):
+ for name in names:
+ pkg = names[name][0]
+ if pkg.installed:
+- iface.warning(_("%s is already installed") % pkg)
++ iface.info(_("%s is already installed") % pkg)
+ else:
+ trans.enqueue(pkg, INSTALL)
+
+diff --git a/smart/interfaces/text/interactive.py b/smart/interfaces/text/interactive.py
+index 9865584..190867b 100644
+--- a/smart/interfaces/text/interactive.py
++++ b/smart/interfaces/text/interactive.py
+@@ -278,7 +278,7 @@ class Interpreter(Cmd):
+ for name in names:
+ pkg = names[name][0]
+ if pkg.installed:
+- iface.warning(_("%s is already installed") % pkg)
++ iface.info(_("%s is already installed") % pkg)
+ else:
+ found = True
+ transaction.enqueue(pkg, INSTALL)
+--
+2.1.0
+
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
index c75f10fbf3..69b94a2134 100644
--- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
+++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb
@@ -34,6 +34,7 @@ SRC_URI = "\
file://smart-filename-NAME_MAX.patch \
file://smart-rpm4-fixes.patch \
file://smart-add-for-rpm-ignoresize-check.patch \
+ file://smart-already-installed-message.patch \
"
SRC_URI[md5sum] = "573ef32ba177a6b3c4bf7ef04873fcb6"