aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu
diff options
context:
space:
mode:
authorJianxun Zhang <jianxun.zhang@linux.intel.com>2016-09-08 12:20:14 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-09 11:52:10 +0100
commit7009a9309051061455fa7237e09796ef12c9e308 (patch)
treefc3afff124f1b966743236d878ad341ee849788f /meta/recipes-devtools/qemu
parent056ce17e168bf856ff95a6f659098403169cb889 (diff)
downloadopenembedded-core-7009a9309051061455fa7237e09796ef12c9e308.tar.gz
qemu: fix: cp command cannot find tests/Makeflie
bitbake qemu This error shows up: ERROR: qemu-2.7.0-r1 do_install_ptest_base: Function failed: do_install_ptest_base ... cp: cannot stat '...tmp/work/core2-64-poky-linux/qemu/2.7.0-r1 /qemu-2.7.0/tests/Makefile: No such file or directory ... Commit 46e7b70699d8bf4db08c8bb5111974318dd5416d in qemu project renamed tests/Makefile to tests/Makefile.include, we apply the same change in recipe accordingly to fix this issue. Fixes [YOCTO #10245] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu')
-rw-r--r--meta/recipes-devtools/qemu/qemu.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index d724aa4bd9..b46e7f72e2 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -76,7 +76,7 @@ do_install_ptest() {
cp -rL ${B}/tests ${D}${PTEST_PATH}
find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
- cp ${S}/tests/Makefile ${D}${PTEST_PATH}/tests
+ cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
}
do_install () {