aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/remake
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-02 11:55:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-02 17:55:05 +0100
commit166c123bc0d121eeea39db71e63940fa2f8a3f7b (patch)
treef4c568b48efd50f392a370d1558c433e2f187d0e /meta/recipes-devtools/remake
parent0c2778c36f521d019ab6ff0c458a1e117808d2e5 (diff)
downloadopenembedded-core-166c123bc0d121eeea39db71e63940fa2f8a3f7b.tar.gz
remake: Fix out of tree builds
remake fails with errors during configure due to the out of tree build changes. This ensures the configure commands run correctly on files in ${S}. [YOCTO #4139] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/remake')
-rw-r--r--meta/recipes-devtools/remake/remake_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/remake/remake_git.bb b/meta/recipes-devtools/remake/remake_git.bb
index a7cf54e320..afbc5d0710 100644
--- a/meta/recipes-devtools/remake/remake_git.bb
+++ b/meta/recipes-devtools/remake/remake_git.bb
@@ -16,10 +16,10 @@ PROVIDES += "make"
do_configure_prepend() {
# remove the default LINGUAS since we are not going to generate languages
- rm po/LINGUAS
- touch po/LINGUAS
+ rm ${S}/po/LINGUAS
+ touch ${S}/po/LINGUAS
# create config.rpath which required by configure.ac
- autopoint || touch config.rpath
+ ( cd ${S}; autopoint || touch config.rpath )
}
BBCLASSEXTEND = "native"