summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/remake
diff options
context:
space:
mode:
authorPetter Mabäcker <petter@technux.se>2013-07-15 18:53:25 +0200
committerSaul Wold <sgw@linux.intel.com>2013-07-23 07:22:37 -0700
commit4bd98157f1d7a96741d036e67b04819ccbc9a9c6 (patch)
tree5f3e9fc3b6321ced81fb8b32d3f2c0b6216f43f2 /meta/recipes-devtools/remake
parent9908ec004bc3e2247e664d97690849253a66bae9 (diff)
downloadopenembedded-core-4bd98157f1d7a96741d036e67b04819ccbc9a9c6.tar.gz
remake: fix insufficient gettext dependency
By default when inheriting gettext, "gettext-minimal-native" is added as a dependency for native. The bb-file for remake use 'autopoint' (not included in gettext-minimal-native). When building remake-native it will result in a failure in do_configure for all cases when gettext (or gettext-native) is not build from some other recipes, before building 'remake-native'. This is solved by adding a build-dependency to gettext-native in remake-native. Fixes [YOCTO #4385] Signed-off-by: Petter Mabäcker <petter@technux.se> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/remake')
-rw-r--r--meta/recipes-devtools/remake/remake_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/remake/remake_git.bb b/meta/recipes-devtools/remake/remake_git.bb
index 13d8ce92a3..405c69f6a6 100644
--- a/meta/recipes-devtools/remake/remake_git.bb
+++ b/meta/recipes-devtools/remake/remake_git.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
file://tests/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
@@ -12,6 +12,10 @@ S = "${WORKDIR}/git"
PV = "3.82+dbg-0.9+git${SRCPV}"
DEPENDS += "readline"
+# Need to add "gettext-native" dependency to remake-native.
+# By default only "gettext-minimal-native" is added
+# when inherit gettext.
+DEPENDS_class-native += "gettext-native"
PROVIDES += "make"
do_configure_prepend() {