summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/sgml-common
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2014-03-18 15:54:34 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-19 14:20:36 +0000
commit50683df81e1605ad7c03bc633aa55da7e97cfe62 (patch)
tree505c7bb36b6212dc5de5999e377040c6ef609f1e /meta/recipes-devtools/sgml-common
parenta8fe5fd62fd98e33180f3de700ed01f9efb74a50 (diff)
downloadopenembedded-core-50683df81e1605ad7c03bc633aa55da7e97cfe62.tar.gz
sgml-common-native: fix the generation of sgml-docbook.cat
There would be build errors if multiple builds use the same SSTATE_DIR, and the builds use the different versions' docbook-sgml-dtd-native, the problems are: we have multiple versions docbook-sgml-dtd-native: docbook-sgml-dtd-3.1-native docbook-sgml-dtd-4.1-native docbook-sgml-dtd-4.5-native And they depend on sgml-common-native which installs the file sysroot/etc/sgml/sgml-docbook.cat, this file is also included in the sstate cache file (.tar.gz), but both the 3 versions docbook-sgml-dtd-native may update the sysroot/ect/sgml/sgml-docbook.cat, and it is a hardlink to SYSROOT_DESTDIR/etc/sgml/sgml-docbook.cat, so the sgml-docbook.cat in the sstate cache file may contain the docbook-sgml-dtd-<version>-native's info, and there would be errors when we mirror the sstate-cache to another build which uses a different version. Now we exclude the sgml-docbook.cat from the ${D}, and generate sysroot/ect/sgml/sgml-docbook.cat dynamically will fix the problem, both the sgml-common-native and docbook-sgml-dtd-<version>-native can update it it correctly. The similar to docbook-dsssl-stylesheets-native and openjade-native. [YOCTO #5994] Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/sgml-common')
-rw-r--r--meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb17
1 files changed, 12 insertions, 5 deletions
diff --git a/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb b/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
index af7e104274..597536570d 100644
--- a/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
+++ b/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
@@ -22,6 +22,7 @@ S = "${WORKDIR}/sgml-common-${PV}"
SYSROOT_PREPROCESS_FUNCS += "sgml_common_native_mangle"
SSTATEPOSTINSTFUNCS += "sgml_common_sstate_postinst"
+CLEANFUNCS += "sgml_common_sstate_clean"
do_install_append() {
@@ -33,9 +34,8 @@ do_install_append() {
--add ${D}${sysconfdir}/sgml/sgml-ent.cat \
${D}${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
- ${D}${bindir}/install-catalog \
- --add ${D}${sysconfdir}/sgml/sgml-docbook.cat \
- ${D}${sysconfdir}/sgml/sgml-ent.cat
+ # The sgml-docbook.cat will be regenerated by sstate_postinst
+ rm -f ${D}${sysconfdir}/sgml/sgml-docbook.cat
}
sgml_common_native_mangle () {
@@ -43,8 +43,6 @@ sgml_common_native_mangle () {
sed -i -e "s|${D}${sysconfdir}/sgml|${sysconfdir}/sgml|g" ${SYSROOT_DESTDIR}${STAGING_BINDIR}/install-catalog
# Change path from ${D}${datadir}/sgml/sgml-iso-entities-8879.1986/catalog to ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog in sgml-ent.cat
sed -i -e "s|${D}${datadir}/sgml/sgml-iso-entities-8879.1986/catalog|${datadir}/sgml/sgml-iso-entities-8879.1986/catalog|g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/sgml-ent.cat
- # Change path from ${D}${sysconfdir}/sgml/sgml-ent.cat|${sysconfdir}/sgml/sgml-ent.cat to ${sysconfdir}/sgml/sgml-ent.cat in sgml-ent.cat
- sed -i -e "s|${D}${sysconfdir}/sgml/sgml-ent.cat|${sysconfdir}/sgml/sgml-ent.cat|g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/sgml-docbook.cat
# Remove ${D} path from catalog file created by install-catalog script
sed -i -e "s|${D}||g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/catalog
}
@@ -52,6 +50,7 @@ sgml_common_native_mangle () {
sgml_common_sstate_postinst() {
if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
then
+ ${bindir}/install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat ${sysconfdir}/sgml/sgml-ent.cat
if [ -e ${sysconfdir}/sgml/sgml-docbook.bak ]; then
for catalog in `awk '{print $2}' ${sysconfdir}/sgml/sgml-docbook.bak`; do
if [ ! `grep $catalog ${sysconfdir}/sgml/sgml-docbook.cat 1> /dev/null 2>&1` ]; then
@@ -62,3 +61,11 @@ sgml_common_sstate_postinst() {
fi
fi
}
+
+sgml_common_sstate_clean () {
+ # Ensure that the catalog file sgml-docbook.cat is properly
+ # updated when the package is removed from sstate cache.
+ if [ -f ${sysconfdir}/sgml/sgml-docbook.cat ]; then
+ sed -i '/\/sgml\/sgml-ent.cat/d' ${sysconfdir}/sgml/sgml-docbook.cat
+ fi
+}