summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/sgml-common
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-16 10:49:45 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-16 12:44:36 +0100
commitc9dcfbd87d749baa0a4948738055193982aad26d (patch)
treee4c6dfbf500d4039c8760797eedad96d5f358696 /meta/recipes-devtools/sgml-common
parentb3df34ba57284fa2c85f34be86d5d8e357becf7c (diff)
downloadopenembedded-core-c9dcfbd87d749baa0a4948738055193982aad26d.tar.gz
sgml-common: Fix re-execution of the compile task
The sed command run during do_compile isn't idempotent. This change fixes it so that it is and the compile task can be re-executed. [YOCTO #2194] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/sgml-common')
-rw-r--r--meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
index 63e0acdba7..27b1a48ebd 100644
--- a/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
+++ b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
@@ -26,7 +26,7 @@ inherit autotools
do_compile_append() {
# install-catalog script contains hardcoded references to /etc/sgml
- sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/install-catalog
+ sed -i -e 's|\([ "]\+\)/etc/sgml|\1${sysconfdir}/sgml|g' bin/install-catalog
}
FILES_sgml-common_append = " ${datadir}/sgml"