summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2014-01-03 14:28:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-06 11:12:31 +0000
commit92bb949465feb39b2460ea0ddb45f259ca8baecc (patch)
tree5b3d2471c43d2eed9df0209e499061e9b54c90f4 /meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
parentcd789ffead8e68c88560931dc3fe689254339e87 (diff)
downloadopenembedded-core-92bb949465feb39b2460ea0ddb45f259ca8baecc.tar.gz
valgrind: rrecommend libc6-dbg on all architectures
It seems that valgrind requires debug symbols to be available on all architectures so there's no reason to treat arm and powerpc specially. Ensuring that libc6-dbg is installed avoids errors like this on x86: valgrind: Fatal error at startup: a function redirection valgrind: which is mandatory for this platform-tool combination valgrind: cannot be set up. Details of the redirection are: valgrind: valgrind: A must-be-redirected function valgrind: whose name matches the pattern: strlen valgrind: in an object with soname matching: ld-linux.so.2 valgrind: was not found whilst processing valgrind: symbols from the object with soname: ld-linux.so.2 valgrind: valgrind: Possible fixes: (1, short term): install glibc's debuginfo valgrind: package on this machine. (2, longer term): ask the packagers valgrind: for your Linux distribution to please in future ship a non- valgrind: stripped ld.so (or whatever the dynamic linker .so is called) valgrind: that exports the above-named function using the standard valgrind: calling conventions for this platform. The package you need valgrind: to install for fix (1) is called valgrind: valgrind: On Debian, Ubuntu: libc6-dbg valgrind: On SuSE, openSuSE, Fedora, RHEL: glibc-debuginfo valgrind: valgrind: Cannot continue -- exiting now. Sorry. Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind_3.9.0.bb')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.9.0.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
index 216fdab5ac..e1fb568d4c 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
@@ -37,6 +37,7 @@ do_install_append () {
RDEPENDS_${PN} += "perl"
FILES_${PN}-dbg += "${libdir}/${PN}/*/.debug/*"
-RRECOMMENDS_${PN}_powerpc += "${TCLIBC}-dbg"
-RRECOMMENDS_${PN}_powerpc64 += "${TCLIBC}-dbg"
-RRECOMMENDS_${PN}_armv7a += "${TCLIBC}-dbg"
+
+# valgrind needs debug information for ld.so at runtime in order to
+# redirect functions like strlen.
+RRECOMMENDS_${PN} += "${TCLIBC}-dbg"