aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-08-21 09:27:13 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-23 23:01:33 +0100
commit43813ddfa8cade9ea1c5de24dcd4e275b1486cff (patch)
tree265b307a09f78b76ffbf0a3adf40527c95efe301 /meta/recipes-devtools
parent7c962ca5d01ae4b9f511bb2b3b7700f970051727 (diff)
downloadopenembedded-core-43813ddfa8cade9ea1c5de24dcd4e275b1486cff.tar.gz
expect: fix shared object file cannot be opened
When we require Expect package in tcl script, we will get following error: couldn't load file "/usr/lib/expect5.45/libexpect5.45.so": /usr/lib/expect5.45/libexpect5.45.so: cannot open shared object file: No such file or directory while executing "load /usr/lib/expect5.45/libexpect5.45.so" ("package ifneeded Expect 5.45" script) invoked from within "package require Expect" (file "hello.tcl" line 3) This patch fixes this issue. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/expect/expect_5.45.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/expect/expect_5.45.bb b/meta/recipes-devtools/expect/expect_5.45.bb
index 970f4a5ccc..3e839a2fe3 100644
--- a/meta/recipes-devtools/expect/expect_5.45.bb
+++ b/meta/recipes-devtools/expect/expect_5.45.bb
@@ -35,6 +35,7 @@ do_install_append() {
install -m 0755 ${S}/fixline1 ${D}${libdir}/expect${PV}/
install -m 0755 ${S}/example/* ${D}${libdir}/expect${PV}/
rm ${D}${libdir}/expect${PV}/libexpect*.so
+ sed -e 's|$dir|${libdir}|' -i ${D}${libdir}/expect${PV}/pkgIndex.tcl
}
EXTRA_OECONF += "--includedir=${STAGING_INCDIR} \