aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-11-16 18:05:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-08 10:20:09 +0000
commit73e2555cc7d529a93362b3fcfea3fbc7a4c60ca1 (patch)
tree2ab0583f3527a67d96ba0be8838d19b56ce44e68 /meta/recipes-devtools
parent1eb9e190ef3bb1170b3eaabd9f7900e7ce176624 (diff)
downloadopenembedded-core-73e2555cc7d529a93362b3fcfea3fbc7a4c60ca1.tar.gz
package_regex.inc: split the rest of the entries to their recipes
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/autogen/autogen-native_5.18.5.bb3
-rw-r--r--meta/recipes-devtools/chrpath/chrpath_0.16.bb2
-rw-r--r--meta/recipes-devtools/cmake/cmake.inc2
-rw-r--r--meta/recipes-devtools/dosfstools/dosfstools_3.0.28.bb2
-rw-r--r--meta/recipes-devtools/intltool/intltool.inc3
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.12.bb5
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.14.bb2
7 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/autogen/autogen-native_5.18.5.bb b/meta/recipes-devtools/autogen/autogen-native_5.18.5.bb
index 2a2851283b..373dd89994 100644
--- a/meta/recipes-devtools/autogen/autogen-native_5.18.5.bb
+++ b/meta/recipes-devtools/autogen/autogen-native_5.18.5.bb
@@ -17,6 +17,9 @@ SRC_URI = "${GNU_MIRROR}/autogen/rel${PV}/autogen-${PV}.tar.gz \
SRC_URI[md5sum] = "385d7c7dfbe60babbee261c054923a53"
SRC_URI[sha256sum] = "7bbdb73b5518baf64c6d3739fb2ecc66d2cccda888ce5ad573abe235ab5d96ba"
+UPSTREAM_CHECK_URI = "http://ftp.gnu.org/gnu/autogen/"
+UPSTREAM_CHECK_REGEX = "rel(?P<pver>\d+(\.\d+)+)/"
+
DEPENDS = "guile-native libtool-native libxml2-native"
inherit autotools texinfo native pkgconfig
diff --git a/meta/recipes-devtools/chrpath/chrpath_0.16.bb b/meta/recipes-devtools/chrpath/chrpath_0.16.bb
index 0a3b06e73b..e115eb5c95 100644
--- a/meta/recipes-devtools/chrpath/chrpath_0.16.bb
+++ b/meta/recipes-devtools/chrpath/chrpath_0.16.bb
@@ -13,6 +13,8 @@ SRC_URI = "http://alioth.debian.org/frs/download.php/file/3979/chrpath-0.16.tar.
SRC_URI[md5sum] = "2bf8d1d1ee345fc8a7915576f5649982"
SRC_URI[sha256sum] = "bb0d4c54bac2990e1bdf8132f2c9477ae752859d523e141e72b3b11a12c26e7b"
+UPSTREAM_CHECK_URI = "http://alioth.debian.org/frs/?group_id=31052"
+
inherit autotools
# We don't have a staged chrpath-native for ensuring our binary is
diff --git a/meta/recipes-devtools/cmake/cmake.inc b/meta/recipes-devtools/cmake/cmake.inc
index c912bcce32..a14ce350fc 100644
--- a/meta/recipes-devtools/cmake/cmake.inc
+++ b/meta/recipes-devtools/cmake/cmake.inc
@@ -19,6 +19,8 @@ SRC_URI = "https://cmake.org/files/v${CMAKE_MAJOR_VERSION}/cmake-${PV}.tar.gz \
SRC_URI[md5sum] = "5febbd11bcaac854a27eebaf4a124be2"
SRC_URI[sha256sum] = "e75a178d6ebf182b048ebfe6e0657c49f0dc109779170bad7ffcb17463f2fc22"
+UPSTREAM_CHECK_REGEX = "cmake-(?P<pver>\d+(\.\d+)+)\.tar"
+
inherit autotools
# Ugly hack to work around undefined OE_QMAKE_PATH_EXTERNAL_HOST_BINS variable
diff --git a/meta/recipes-devtools/dosfstools/dosfstools_3.0.28.bb b/meta/recipes-devtools/dosfstools/dosfstools_3.0.28.bb
index ac131cb72a..addcbf607c 100644
--- a/meta/recipes-devtools/dosfstools/dosfstools_3.0.28.bb
+++ b/meta/recipes-devtools/dosfstools/dosfstools_3.0.28.bb
@@ -13,6 +13,8 @@ SRC_URI = "https://github.com/dosfstools/dosfstools/releases/download/v3.0.28/do
SRC_URI[md5sum] = "6a047a6c65186b9ebb1853709adb36db"
SRC_URI[sha256sum] = "ee95913044ecf2719b63ea11212917649709a6e53209a72d622135aaa8517ee2"
+UPSTREAM_CHECK_URI = "https://github.com/dosfstools/dosfstools/releases"
+
FILES_${PN} = "${base_sbindir}"
FILES_${PN}-doc = "${mandir} ${docdir}"
diff --git a/meta/recipes-devtools/intltool/intltool.inc b/meta/recipes-devtools/intltool/intltool.inc
index be77704208..eb7ae004aa 100644
--- a/meta/recipes-devtools/intltool/intltool.inc
+++ b/meta/recipes-devtools/intltool/intltool.inc
@@ -4,6 +4,9 @@ LICENSE = "GPLv2"
URLV="${@'.'.join(d.getVar('PV',1).split('.')[0:2])}"
SRC_URI = "http://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz"
+
+UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/"
+
S = "${WORKDIR}/intltool-${PV}"
DEPENDS = "libxml-parser-perl-native"
diff --git a/meta/recipes-devtools/json-c/json-c_0.12.bb b/meta/recipes-devtools/json-c/json-c_0.12.bb
index cfef03d2e8..b56b37e864 100644
--- a/meta/recipes-devtools/json-c/json-c_0.12.bb
+++ b/meta/recipes-devtools/json-c/json-c_0.12.bb
@@ -11,6 +11,11 @@ SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
SRC_URI[md5sum] = "3ca4bbb881dfc4017e8021b5e0a8c491"
SRC_URI[sha256sum] = "000c01b2b3f82dcb4261751eb71f1b084404fb7d6a282f06074d3c17078b9f3f"
+UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
+# json-c releases page is fetching the list of releases in some weird XML format
+# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
+#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
+
RPROVIDES_${PN} = "libjson"
inherit autotools
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.14.bb b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
index 8e1d3cbfc6..774a1a30e0 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.14.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
@@ -112,6 +112,8 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.14-0.20131024.src.rpm;e
SRC_URI[md5sum] = "25093d399a0b5d1342d24900a91b347d"
SRC_URI[sha256sum] = "676e3ab41f72e3b504e04109cfb565a300742f56a7da084f202013b30eeae467"
+UPSTREAM_CHECK_REGEX = "rpm-(?P<pver>(\d+[\.\-_]*)+)-.*$"
+
inherit autotools gettext
acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"