aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-07 13:54:18 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-11 11:46:46 +0000
commit980140fc0735df66592c09acda9686386711f2b5 (patch)
tree4205475575a5d25796745ba56804d66b01a2d8b3 /meta/recipes-devtools
parentf884ee9b911d1ce38b84d90113113c6e8c30253b (diff)
downloadopenembedded-core-980140fc0735df66592c09acda9686386711f2b5.tar.gz
subversion: Fix issues in LDFLAGS sed manipulation
The existing sed expression can match expressions like --sysroot=/some/path/xxx-linux/ which clearly isn't intended and injects incorrect paths into LDFLAGS. Fix this in the same way we address the problem in CFLAGS. This fixes corrupt build paths and incorrect paths in .la files amongst other issues. (From OE-Core rev: 9a8382422ddbb0972dc25b752204f4908bb9857c) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/subversion/subversion/serfmacro.patch22
-rw-r--r--meta/recipes-devtools/subversion/subversion_1.9.4.bb1
2 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/subversion/subversion/serfmacro.patch b/meta/recipes-devtools/subversion/subversion/serfmacro.patch
new file mode 100644
index 0000000000..9a45cb9a01
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion/serfmacro.patch
@@ -0,0 +1,22 @@
+The existing sed expression can match expressions like
+--sysroot=/some/path/xxx-linux/ which clearly isn't intended and
+injects incorrect paths into LDFLAGS.
+
+Fix this in the same way we address the problem in CFLAGS.
+
+RP 2016/12/7
+Upstream-Status: Pending
+
+Index: subversion-1.9.4/build/ac-macros/serf.m4
+===================================================================
+--- subversion-1.9.4.orig/build/ac-macros/serf.m4
++++ subversion-1.9.4/build/ac-macros/serf.m4
+@@ -171,7 +171,7 @@ AC_DEFUN(SVN_SERF_PKG_CONFIG,
+ SVN_SERF_INCLUDES=[`$PKG_CONFIG $serf_pc_arg --cflags | $SED -e 's/ -D[^ ]*//g' -e 's/^-D[^ ]*//g'`]
+ SVN_SERF_LIBS=`$PKG_CONFIG $serf_pc_arg --libs-only-l`
+ dnl don't use --libs-only-L because then we might miss some options
+- LDFLAGS=["$LDFLAGS `$PKG_CONFIG $serf_pc_arg --libs | $SED -e 's/-l[^ ]*//g'`"]
++ LDFLAGS=["$LDFLAGS `$PKG_CONFIG $serf_pc_arg --libs | $SED -e 's/ -l[^ ]*//g' -e 's/^-l[^ ]*//g'`"]
+ break
+ else
+ AC_MSG_RESULT([no])
diff --git a/meta/recipes-devtools/subversion/subversion_1.9.4.bb b/meta/recipes-devtools/subversion/subversion_1.9.4.bb
index fa6a7f238c..3e35940755 100644
--- a/meta/recipes-devtools/subversion/subversion_1.9.4.bb
+++ b/meta/recipes-devtools/subversion/subversion_1.9.4.bb
@@ -15,6 +15,7 @@ SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
file://serf.m4-Regex-modified-to-allow-D-in-paths.patch \
file://0001-Fix-libtool-name-in-configure.ac.patch \
file://0001-fix-svnadmin-create-fail-on-x86.patch \
+ file://serfmacro.patch \
"
SRC_URI[md5sum] = "29121a038f87641055a8183f49e9739f"