aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-14 14:33:23 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-15 16:28:24 +0000
commit9e6743e01467ffb08d62b7415fa7af79c09939e0 (patch)
tree8771fbf4807bf07cf0fe5843f6095b6f5ebbd2b9 /meta/recipes-devtools
parentf879f452dc69989aa227b8dc60b7cb0354203575 (diff)
downloadopenembedded-core-9e6743e01467ffb08d62b7415fa7af79c09939e0.tar.gz
gdb: Rationalise PACKAGECONFIG
Having two separate PACKAGECONFIG defaults and settings in two separate files is confusing. Move all to the common inc file. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/gdb/gdb-common.inc2
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.10.1.bb4
2 files changed, 2 insertions, 4 deletions
diff --git a/meta/recipes-devtools/gdb/gdb-common.inc b/meta/recipes-devtools/gdb/gdb-common.inc
index 06272a99a3..0d28ee4eef 100644
--- a/meta/recipes-devtools/gdb/gdb-common.inc
+++ b/meta/recipes-devtools/gdb/gdb-common.inc
@@ -45,6 +45,8 @@ EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x --disable-werror \
PACKAGECONFIG ??= "readline"
# Use --without-system-readline to compile with readline 5.
PACKAGECONFIG[readline] = "--with-system-readline,--without-system-readline,readline"
+PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python,python python-codecs"
+PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
GDBPROPREFIX = "--program-prefix=''"
diff --git a/meta/recipes-devtools/gdb/gdb_7.10.1.bb b/meta/recipes-devtools/gdb/gdb_7.10.1.bb
index cd52e27d56..f897e1213e 100644
--- a/meta/recipes-devtools/gdb/gdb_7.10.1.bb
+++ b/meta/recipes-devtools/gdb/gdb_7.10.1.bb
@@ -3,10 +3,6 @@ require gdb-${PV}.inc
inherit python-dir
-PACKAGECONFIG ??= ""
-PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python,python python-codecs"
-PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
-
do_configure_prepend() {
if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
cat > ${WORKDIR}/python << EOF