aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2011-06-24 13:30:15 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-28 13:50:17 +0100
commite8da02aeae4b3c1c2a805d63d6d0919d3034aba6 (patch)
tree81ae1e88533c59188205314fb8e5b6704e82206e /meta/recipes-devtools
parent70a786ad881607f6312fe80655c79ab81c53996a (diff)
downloadopenembedded-core-e8da02aeae4b3c1c2a805d63d6d0919d3034aba6.tar.gz
prelink: Uprev prelink to latest version
The latest cross-prelink version tracks the prelink r190 SVN. Fix two minor issues as well. If we remove the package, we would unprelink the filesystem after the rm was finished. This is incorrect.. we need to do this prerm. Move the cron and cron configuration file to a new package split. This item is not valid for most embedded users. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/prelink/prelink/prelink.default2
-rw-r--r--meta/recipes-devtools/prelink/prelink_git.bb25
2 files changed, 23 insertions, 4 deletions
diff --git a/meta/recipes-devtools/prelink/prelink/prelink.default b/meta/recipes-devtools/prelink/prelink/prelink.default
index 901258ed2a..d8802f820a 100644
--- a/meta/recipes-devtools/prelink/prelink/prelink.default
+++ b/meta/recipes-devtools/prelink/prelink/prelink.default
@@ -2,7 +2,7 @@
# or to yes to enable it.
# (if you change this from yes to no prelink -ua
# will be run next night to undo prelinking)
-PRELINKING=unknown
+PRELINKING=yes
# Options to pass to prelink
# -m Try to conserve virtual memory by allowing overlapping
diff --git a/meta/recipes-devtools/prelink/prelink_git.bb b/meta/recipes-devtools/prelink/prelink_git.bb
index 1eea30a5f5..b57c145353 100644
--- a/meta/recipes-devtools/prelink/prelink_git.bb
+++ b/meta/recipes-devtools/prelink/prelink_git.bb
@@ -8,9 +8,24 @@ and executables, so that far fewer relocations need to be resolved at \
runtime and thus programs come up faster."
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
-SRCREV = "909470ee441237563d6236c505cb2d02ddc48704"
+SRCREV = "ac461e73b17253a4da25c5aafeac7193b553156c"
PV = "1.0+git${SRCPV}"
-PR = "r2"
+PR = "r3"
+
+#
+# The cron script attempts to re-prelink the system daily -- on
+# systems where users are adding applications, this might be reasonable
+# but for embedded, we should be re-running prelink -a after an update.
+#
+# Default is prelinking is enabled.
+#
+SUMMARY_${PN}-cron = "Cron scripts to control automatic prelinking"
+DESCRIPTION_${PN}-cron = "Cron scripts to control automatic prelinking. \
+See: ${sysconfdir}/cron.daily/prelink for configuration information."
+
+FILES_${PN}-cron = "${sysconfdir}/cron.daily ${sysconfdir}/default"
+
+PACKAGES =+ "${PN}-cron"
SRC_URI = "git://git.yoctoproject.org/prelink-cross.git;protocol=git \
file://prelink.conf \
@@ -53,9 +68,13 @@ fi
prelink -a
}
-pkg_postrm_prelink() {
+pkg_prerm_prelink() {
#!/bin/sh
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
prelink -au
}