summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-28 22:29:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-30 23:01:28 +0100
commit2d51e2ff2f77fc6b14e50bd3a32998953d809a48 (patch)
treeb4798ef8bf4e8d0657296df58b7f887939221e50 /meta/recipes-devtools
parent713ac3bfbc95e58ce3332409bae838053fdeced8 (diff)
downloadopenembedded-core-2d51e2ff2f77fc6b14e50bd3a32998953d809a48.tar.gz
bison: fix parallel issue
Fixed: rm -f src/yacc src/yacc.tmp echo '#! /bin/sh' >src/yacc.tmp /bin/bash: src/yacc.tmp: No such file or directory Makefile:6670: recipe for target 'src/yacc' failed Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/bison/bison/0001-src-local.mk-fix-parallel-issue.patch33
-rw-r--r--meta/recipes-devtools/bison/bison_3.0.4.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/bison/bison/0001-src-local.mk-fix-parallel-issue.patch b/meta/recipes-devtools/bison/bison/0001-src-local.mk-fix-parallel-issue.patch
new file mode 100644
index 0000000000..9543a56f1e
--- /dev/null
+++ b/meta/recipes-devtools/bison/bison/0001-src-local.mk-fix-parallel-issue.patch
@@ -0,0 +1,33 @@
+From 3a15f7c9ace6c0294edc313a1848cafcc31b2a92 Mon Sep 17 00:00:00 2001
+From: Robert Yang <liezhi.yang@windriver.com>
+Date: Fri, 24 Apr 2015 00:38:32 -0700
+Subject: [PATCH] src/local.mk: fix parallel issue
+
+Fixed:
+rm -f src/yacc src/yacc.tmp
+echo '#! /bin/sh' >src/yacc.tmp
+/bin/bash: src/yacc.tmp: No such file or directory
+Makefile:6670: recipe for target 'src/yacc' failed
+
+Upstream-Status: Pending
+
+Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
+---
+ src/local.mk | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/local.mk b/src/local.mk
+index 573ad00..28bfae4 100644
+--- a/src/local.mk
++++ b/src/local.mk
+@@ -119,6 +119,7 @@ MOSTLYCLEANFILES += src/yacc
+
+ src/yacc:
+ $(AM_V_GEN)rm -f $@ $@.tmp
++ $(AM_V_at)$(MKDIR_P) src
+ $(AM_V_at)echo '#! /bin/sh' >$@.tmp
+ $(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@.tmp
+ $(AM_V_at)chmod a+x $@.tmp
+--
+1.7.9.5
+
diff --git a/meta/recipes-devtools/bison/bison_3.0.4.bb b/meta/recipes-devtools/bison/bison_3.0.4.bb
index de295060e9..708e9a3fd8 100644
--- a/meta/recipes-devtools/bison/bison_3.0.4.bb
+++ b/meta/recipes-devtools/bison/bison_3.0.4.bb
@@ -13,6 +13,7 @@ SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
file://m4.patch \
file://0001-Unset-need_charset_alias-when-building-for-musl.patch \
file://dont-depend-on-help2man.patch.patch \
+ file://0001-src-local.mk-fix-parallel-issue.patch \
"
# No point in hardcoding path to m4, just use PATH