summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2011-02-02 16:10:33 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-03 10:04:35 +0000
commit3eef8470547beed186c38a7da44cb8e22e1497e8 (patch)
treeece8d254f148aa33a11b9d34ec659661d74edd51 /meta/recipes-devtools
parentefbaabd06cafb312657e7c4b420f5dbf2324d5db (diff)
downloadopenembedded-core-3eef8470547beed186c38a7da44cb8e22e1497e8.tar.gz
docbook-utils: fix build errors
Fix build errors found in my first iteration of the recipe. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/docbook-utils/docbook-utils_0.6.14.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/docbook-utils/docbook-utils_0.6.14.bb b/meta/recipes-devtools/docbook-utils/docbook-utils_0.6.14.bb
index 4b053b1a0f..feeb23128b 100644
--- a/meta/recipes-devtools/docbook-utils/docbook-utils_0.6.14.bb
+++ b/meta/recipes-devtools/docbook-utils/docbook-utils_0.6.14.bb
@@ -17,4 +17,34 @@ SRC_URI[sha256sum] = "48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df
inherit autotools
+do_configure_prepend_virtclass-native() {
+ # Fix hard-coded references to /etc/sgml
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/jw.in
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/man/Makefile.am
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" doc/HTML/Makefile.am
+}
+
+do_install_virtclass-native() {
+ install -d ${D}${bindir}
+ # Install the binaries and a bunch of other commonly used names for them.
+ for doctype in html ps dvi man pdf rtf tex texi txt
+ do
+ install -m 0755 ${S}/bin/docbook2$doctype ${D}${bindir}/
+ ln -sf docbook2x-$doctype ${D}${bindir}/db2$doctype
+ ln -sf docbook2$doctype ${D}${bindir}/db2$doctype
+ ln -sf docbook2$doctype ${D}${bindir}/docbook-to-$doctype
+ done
+
+ install -m 0755 ${S}/bin/jw ${D}${bindir}/
+ for i in backends/dvi backends/html backends/man \
+ backends/pdf backends/ps backends/rtf backends/tex \
+ backends/texi backends/txt frontends/docbook \
+ helpers/docbook2man-spec.pl helpers/docbook2texi-spec.pl \
+ docbook-utils.dsl
+ do
+ install -d ${D}${datadir}/sgml/docbook/utils-${PV}/`dirname $i`
+ install ${S}/$i ${D}${datadir}/sgml/docbook/utils-${PV}/$i
+ done
+}
+
BBCLASSEXTEND = "native"