summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-16 16:54:26 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-18 22:52:13 +0000
commit7386a116222979e6de60c39d2c094d5f216fb101 (patch)
tree2130f8c15f51c2935e076790429cd2b41050b81f /meta/recipes-devtools
parent47201e98bb293d59c5d41986d066fd7614b914fa (diff)
downloadopenembedded-core-7386a116222979e6de60c39d2c094d5f216fb101.tar.gz
pseudo: Drop patches merged into upstream branch
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/pseudo/files/0002-pseudo_client-Lessen-indentation-of-pseudo_client_ig.patch69
-rw-r--r--meta/recipes-devtools/pseudo/files/0003-pseudo_client-Simplify-pseudo_client_ignore_path_chr.patch50
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb4
3 files changed, 1 insertions, 122 deletions
diff --git a/meta/recipes-devtools/pseudo/files/0002-pseudo_client-Lessen-indentation-of-pseudo_client_ig.patch b/meta/recipes-devtools/pseudo/files/0002-pseudo_client-Lessen-indentation-of-pseudo_client_ig.patch
deleted file mode 100644
index e4a5356f5c..0000000000
--- a/meta/recipes-devtools/pseudo/files/0002-pseudo_client-Lessen-indentation-of-pseudo_client_ig.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 28c760542eecd7c5b35ea88aa2b14d62afbda961 Mon Sep 17 00:00:00 2001
-From: Peter Kjellerstedt <pkj@axis.com>
-Date: Sat, 21 Nov 2020 17:22:38 +0100
-Subject: [PATCH] pseudo_client: Lessen indentation of
- pseudo_client_ignore_path_chroot()
-
-Change-Id: I739b18efb7a95ce2d2d907d0faf7df539ab9af1c
----
- pseudo_client.c | 45 +++++++++++++++++++++++++--------------------
- 1 file changed, 25 insertions(+), 20 deletions(-)
-
-diff --git a/pseudo_client.c b/pseudo_client.c
-index 116d926..a8bc3dc 100644
---- a/pseudo_client.c
-+++ b/pseudo_client.c
-@@ -1527,28 +1527,33 @@ int pseudo_client_ignore_fd(int fd) {
-
- int pseudo_client_ignore_path_chroot(const char *path, int ignore_chroot) {
- char *env;
-- if (path) {
-- if (ignore_chroot && pseudo_chroot && strncmp(path, pseudo_chroot, pseudo_chroot_len) == 0)
-- return 0;
-- env = pseudo_get_value("PSEUDO_IGNORE_PATHS");
-- if (env) {
-- char *p = env;
-- while (*p) {
-- char *next = strchr(p, ',');
-- if (!next)
-- next = strchr(p, '\0');
-- if ((next - p) && !strncmp(path, p, next - p)) {
-- pseudo_debug(PDBGF_PATH | PDBGF_VERBOSE, "ignoring path: '%s'\n", path);
-- return 1;
-- }
-- if (next && *next != '\0')
-- p = next+1;
-- else
-- break;
-- }
-- free(env);
-+
-+ if (!path)
-+ return 0;
-+
-+ if (ignore_chroot && pseudo_chroot && strncmp(path, pseudo_chroot, pseudo_chroot_len) == 0)
-+ return 0;
-+
-+ env = pseudo_get_value("PSEUDO_IGNORE_PATHS");
-+ if (!env)
-+ return 0;
-+
-+ char *p = env;
-+ while (*p) {
-+ char *next = strchr(p, ',');
-+ if (!next)
-+ next = strchr(p, '\0');
-+ if ((next - p) && !strncmp(path, p, next - p)) {
-+ pseudo_debug(PDBGF_PATH | PDBGF_VERBOSE, "ignoring path: '%s'\n", path);
-+ return 1;
- }
-+ if (next && *next != '\0')
-+ p = next+1;
-+ else
-+ break;
- }
-+ free(env);
-+
- return 0;
- }
-
diff --git a/meta/recipes-devtools/pseudo/files/0003-pseudo_client-Simplify-pseudo_client_ignore_path_chr.patch b/meta/recipes-devtools/pseudo/files/0003-pseudo_client-Simplify-pseudo_client_ignore_path_chr.patch
deleted file mode 100644
index a657a27f28..0000000000
--- a/meta/recipes-devtools/pseudo/files/0003-pseudo_client-Simplify-pseudo_client_ignore_path_chr.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From a1d61d68777373a50ae23b9dd83b428abe2f748d Mon Sep 17 00:00:00 2001
-From: Peter Kjellerstedt <pkj@axis.com>
-Date: Sat, 21 Nov 2020 17:30:33 +0100
-Subject: [PATCH] pseudo_client: Simplify pseudo_client_ignore_path_chroot()
-
-This also plugs a memory leak by making sure env is freed.
-
-Change-Id: Ia8635fd2c6b1e85919e4743713a85e0b52c28fac
----
- pseudo_client.c | 21 ++++++++++-----------
- 1 file changed, 10 insertions(+), 11 deletions(-)
-
-diff --git a/pseudo_client.c b/pseudo_client.c
-index a8bc3dc..7dc0345 100644
---- a/pseudo_client.c
-+++ b/pseudo_client.c
-@@ -1538,23 +1538,22 @@ int pseudo_client_ignore_path_chroot(const char *path, int ignore_chroot) {
- if (!env)
- return 0;
-
-+ int ret = 0;
- char *p = env;
-- while (*p) {
-+ while (p) {
- char *next = strchr(p, ',');
-- if (!next)
-- next = strchr(p, '\0');
-- if ((next - p) && !strncmp(path, p, next - p)) {
-- pseudo_debug(PDBGF_PATH | PDBGF_VERBOSE, "ignoring path: '%s'\n", path);
-- return 1;
-- }
-- if (next && *next != '\0')
-- p = next+1;
-- else
-+ if (next)
-+ *next++ = '\0';
-+ if (*p && !strncmp(path, p, strlen(p))) {
-+ pseudo_debug(PDBGF_PATH | PDBGF_VERBOSE, "ignoring path: '%s'\n", path);
-+ ret = 1;
- break;
-+ }
-+ p = next;
- }
- free(env);
-
-- return 0;
-+ return ret;
- }
-
- int pseudo_client_ignore_path(const char *path) {
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index a9f7aa966a..78c6b01f09 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -4,11 +4,9 @@ SRC_URI = "git://git.yoctoproject.org/pseudo;branch=oe-core \
file://0001-configure-Prune-PIE-flags.patch \
file://fallback-passwd \
file://fallback-group \
- file://0002-pseudo_client-Lessen-indentation-of-pseudo_client_ig.patch \
- file://0003-pseudo_client-Simplify-pseudo_client_ignore_path_chr.patch \
"
-SRCREV = "69f205c41902e17933b81b1450636848e8da2126"
+SRCREV = "6fd57da7b1de1a2b6cf530e336d58bb5f8bdd015"
S = "${WORKDIR}/git"
PV = "1.9.0+git${SRCPV}"