summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-12-01 11:26:25 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-06 15:23:13 +0000
commit9e5ec22183a8b0f16817fd3dd2e3b45b292a3a09 (patch)
tree41e1471a7b1616e5b0988954258ae6a839817724 /meta/recipes-devtools
parent95b5c89066baccb1e64bfba7d9a66feeeb086da9 (diff)
downloadopenembedded-core-9e5ec22183a8b0f16817fd3dd2e3b45b292a3a09.tar.gz
pseudo: Disable LFS on 32bit arches
pseudo overrides certain libc functions which are aliases when LFS64 is enabled. In anycase pseudo may not be of much use on 32bit systems Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index c34580b4ff..8bb8993439 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -17,5 +17,12 @@ SRCREV = "c9670c27ff67ab899007ce749254b16091577e55"
S = "${WORKDIR}/git"
PV = "1.9.0+git${SRCPV}"
+# largefile and 64bit time_t support adds these macros via compiler flags globally
+# remove them for pseudo since pseudo intercepts some of the functions which will be
+# aliased due to this e.g. open/open64 and it will complain about duplicate definitions
+# pseudo on 32bit systems is not much of use anyway and these features are not of much
+# use for it.
+TARGET_CPPFLAGS:remove = "-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
+
# error: use of undeclared identifier '_STAT_VER'
COMPATIBLE_HOST:libc-musl = 'null'