summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-20 11:59:49 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-21 14:49:34 +0100
commitd6806b449ba8b44fd74dfb05c65b9233b6f3ace5 (patch)
treeb51f2c69933055874c05b5f9dc1274d657326699 /meta/recipes-devtools
parent793a15af9f5d522673693ccb22addf76bec1060c (diff)
downloadopenembedded-core-d6806b449ba8b44fd74dfb05c65b9233b6f3ace5.tar.gz
gdb: Alias rpl_stat to stat() on musl
Use CPPFLAGS instead of CFLAGS since there is C++ compiler being used for somefiles Fixes gdb/gdbserver/../../../gdb-8.1.1/gdb/gdbserver/../common/common-utils.c:419: undefined reference to `rpl_stat' | collect2: error: ld returned 1 exit status | make[4]: *** [Makefile:414: libinproctrace.so] Error 1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/gdb/gdb_8.1.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_8.1.1.bb b/meta/recipes-devtools/gdb/gdb_8.1.1.bb
index 84ab08ce93..c6eac84dd8 100644
--- a/meta/recipes-devtools/gdb/gdb_8.1.1.bb
+++ b/meta/recipes-devtools/gdb/gdb_8.1.1.bb
@@ -26,4 +26,4 @@ EOF
chmod +x ${WORKDIR}/python
fi
}
-CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday"
+CPPFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday -Drpl_stat=stat"