summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2010-08-31 22:51:58 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 09:50:49 +0100
commitdd5509458fa5f78a3d4358b8a22dfdee40cac660 (patch)
treee1933fd3046d8d67f56d356ab3ba7a941fab8948 /meta/recipes-devtools
parent33ed325337c279061c372743753038c91268d830 (diff)
downloadopenembedded-core-dd5509458fa5f78a3d4358b8a22dfdee40cac660.tar.gz
valgrind: fix perl scripts
svn version of valgrind uses #! @PERL@ for several perl scripts. However, PERL in autoconf doesn't distinguish host perl and target perl, causing STAGING_DIR_NATIVE be written in the output scripts. This causes unrunnable scripts, and fails FILERDEPENDS mechanism (thus also do_rootfs_rpm). Uses /usr/bin/perl instead to fix it. Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind/fixed-perl-path.patch51
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.5.0.bb5
2 files changed, 54 insertions, 2 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind/fixed-perl-path.patch b/meta/recipes-devtools/valgrind/valgrind/fixed-perl-path.patch
new file mode 100644
index 0000000000..2a0440a1b0
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind/fixed-perl-path.patch
@@ -0,0 +1,51 @@
+this is a temporary patch to workaround cross compilation.
+otherwise @PERL@ will be replaced to perl-native binary,
+this creates unusable scripts and fails FILERDEPENDS mechanism
+(esp. rpm)
+
+a better fix would need:
+ 1. configure.ac should differentiate PERL and HOSTPERL
+ 2. optionally remove ${STAGING_DIR} in #! line before do_install
+
+8/31/2010 - created by Qing He <qing.he@intel.com>
+
+diff --git a/cachegrind/cg_annotate.in b/cachegrind/cg_annotate.in
+index 9dc9565..cc4ef05 100644
+--- a/cachegrind/cg_annotate.in
++++ b/cachegrind/cg_annotate.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+
+ ##--------------------------------------------------------------------##
+ ##--- Cachegrind's annotator. cg_annotate.in ---##
+diff --git a/cachegrind/cg_diff.in b/cachegrind/cg_diff.in
+index 951066e..84c2dde 100644
+--- a/cachegrind/cg_diff.in
++++ b/cachegrind/cg_diff.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+
+ ##--------------------------------------------------------------------##
+ ##--- Cachegrind's differencer. cg_diff.in ---##
+diff --git a/massif/ms_print.in b/massif/ms_print.in
+index e6ffdbf..fb45906 100755
+--- a/massif/ms_print.in
++++ b/massif/ms_print.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+
+ ##--------------------------------------------------------------------##
+ ##--- Massif's results printer ms_print.in ---##
+diff --git a/perf/vg_perf.in b/perf/vg_perf.in
+index 2188a31..83ad024 100644
+--- a/perf/vg_perf.in
++++ b/perf/vg_perf.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+ ##--------------------------------------------------------------------##
+ ##--- Valgrind performance testing script vg_perf ---##
+ ##--------------------------------------------------------------------##
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.5.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.5.0.bb
index c1a73f878d..6eba66e5bd 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.5.0.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.5.0.bb
@@ -7,11 +7,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=c46082167a314d785d012a244748d803 \
file://include/valgrind.h;beginline=1;endline=56;md5=13a71cedba99112334d8596162aec37e \
file://COPYING.DOCS;md5=8fdeb5abdb235a08e76835f8f3260215"
DEPENDS = "virtual/libx11"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
file://valgrind_3.5.0-svn_r11264.patch.bz2 \
- file://fix_issue_caused_by_ccache.patch "
+ file://fix_issue_caused_by_ccache.patch \
+ file://fixed-perl-path.patch"
COMPATIBLE_HOST = '(i.86|x86_64).*-linux'