aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at
diff options
context:
space:
mode:
authorMei Lei <lei.mei@intel.com>2010-10-21 12:36:51 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-21 13:52:01 +0100
commit0e0d14ed1e88ebff876abb3d00b08627a3879e8d (patch)
tree335844d5b995e324425c748c89b734aed87dc37a /meta/recipes-extended/at
parent27d06858b5f3138039bddecc0eaaee1e05e21b48 (diff)
downloadopenembedded-core-0e0d14ed1e88ebff876abb3d00b08627a3879e8d.tar.gz
at: remove nonrootinstall patch and modify some relevant files
remove nonrootinstall patch, and use a patch named nonstripbinaries to modi fy the /at-3.1.10.2/Makefile.in, so it can also handles stripping of the bi naries Fix [BUG 246] Signed-off-by: Mei Lei <lei.mei@intel.com>
Diffstat (limited to 'meta/recipes-extended/at')
-rw-r--r--meta/recipes-extended/at/at_3.1.12.bb2
-rw-r--r--meta/recipes-extended/at/files/nonrootinstall.patch75
-rw-r--r--meta/recipes-extended/at/files/nonstripbinaries.patch25
3 files changed, 26 insertions, 76 deletions
diff --git a/meta/recipes-extended/at/at_3.1.12.bb b/meta/recipes-extended/at/at_3.1.12.bb
index 999aa7fe3d..3be9489e4d 100644
--- a/meta/recipes-extended/at/at_3.1.12.bb
+++ b/meta/recipes-extended/at/at_3.1.12.bb
@@ -9,8 +9,8 @@ PR = "r3"
SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
file://configure.patch \
- file://nonrootinstall.patch \
file://use-ldflags.patch \
+ file://nonstripbinaries.patch \
file://fix_parallel_build_error.patch \
file://posixtm.c \
file://posixtm.h \
diff --git a/meta/recipes-extended/at/files/nonrootinstall.patch b/meta/recipes-extended/at/files/nonrootinstall.patch
deleted file mode 100644
index f760e85ae8..0000000000
--- a/meta/recipes-extended/at/files/nonrootinstall.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-# Modify install rules to disable file ownership changes
-# Disable stripping binaries
-# Derived from an OE patch for at-3.1.8
-
---- at-3.1.10.2.orig/Makefile.in 2005-08-29 01:08:28.000000000 -0700
-+++ at-3.1.10.2/Makefile.in 2010-07-21 17:06:01.000000000 -0700
-@@ -40,6 +40,10 @@
- LIBS = @LIBS@
- LIBOBJS = @LIBOBJS@
- INSTALL = @INSTALL@
-+ifeq ($(IROOT),)
-+INSTALLOWN = -g root -o root
-+DAEMONOWN = -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME)
-+endif
- PAMLIB = @PAMLIB@
-
- CLONES = atq atrm
-@@ -88,35 +92,38 @@
- $(CC) -c $(CFLAGS) $(DEFS) $*.c
-
- install: all
-- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(etcdir)
-- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(bindir)
-- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(sbindir)
-- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(docdir)
-- $(INSTALL) -g root -o root -m 755 -d $(IROOT)$(atdocdir)
-- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 755 -d $(IROOT)$(ATSPOOL_DIR) $(IROOT)$(ATJOB_DIR)
-+ $(INSTALL) $(INSTALLOWN) -m 755 -d $(IROOT)$(etcdir)
-+ $(INSTALL) $(INSTALLOWN) -m 755 -d $(IROOT)$(bindir)
-+ $(INSTALL) $(INSTALLOWN) -m 755 -d $(IROOT)$(sbindir)
-+ $(INSTALL) $(INSTALLOWN) -m 755 -d $(IROOT)$(docdir)
-+ $(INSTALL) $(INSTALLOWN) -m 755 -d $(IROOT)$(atdocdir)
-+ $(INSTALL) $(INSTALLOWN) -m 755 -d $(IROOT)$(ATJOB_DIR)
-+ $(INSTALL) $(DAEMONOWN) -m 755 -d $(IROOT)$(ATSPOOL_DIR)
- chmod 1770 $(IROOT)$(ATSPOOL_DIR) $(IROOT)$(ATJOB_DIR)
- touch $(IROOT)$(LFILE)
- chmod 600 $(IROOT)$(LFILE)
-+ifeq ($(IROOT),)
- chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(LFILE)
-- test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(IROOT)$(etcdir)/
-- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 -s at $(IROOT)$(bindir)
-+endif
-+ test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) $(INSTALLOWN) -m 600 at.deny $(IROOT)$(etcdir)/
-+ $(INSTALL) $(INSTALLOWN) -m 4755 at $(IROOT)$(bindir)
- $(LN_S) -f at $(IROOT)$(bindir)/atq
- $(LN_S) -f at $(IROOT)$(bindir)/atrm
-- $(INSTALL) -g root -o root -m 755 batch $(IROOT)$(bindir)
-- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man1dir)
-- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man5dir)
-- $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man8dir)
-- $(INSTALL) -g root -o root -m 755 -s atd $(IROOT)$(sbindir)
-- $(INSTALL) -g root -o root -m 755 atrun $(IROOT)$(sbindir)
-- $(INSTALL) -g root -o root -m 644 at.1 $(IROOT)$(man1dir)/
-+ $(INSTALL) $(INSTALLOWN) -m 755 batch $(IROOT)$(bindir)
-+ $(INSTALL) -d $(INSTALLOWN) -m 755 $(IROOT)$(man1dir)
-+ $(INSTALL) -d $(INSTALLOWN) -m 755 $(IROOT)$(man5dir)
-+ $(INSTALL) -d $(INSTALLOWN) -m 755 $(IROOT)$(man8dir)
-+ $(INSTALL) $(INSTALLOWN) -m 755 atd $(IROOT)$(sbindir)
-+ $(INSTALL) $(INSTALLOWN) -m 755 atrun $(IROOT)$(sbindir)
-+ $(INSTALL) $(INSTALLOWN) -m 644 at.1 $(IROOT)$(man1dir)/
- cd $(IROOT)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1
-- $(INSTALL) -g root -o root -m 644 atd.8 $(IROOT)$(man8dir)/
-+ $(INSTALL) $(INSTALLOWN) -m 644 atd.8 $(IROOT)$(man8dir)/
- sed "s,\$${exec_prefix},$(exec_prefix),g" <atrun.8>tmpman
-- $(INSTALL) -g root -o root -m 644 tmpman $(IROOT)$(man8dir)/atrun.8
-+ $(INSTALL) $(INSTALLOWN) -m 644 tmpman $(IROOT)$(man8dir)/atrun.8
- rm -f tmpman
-- $(INSTALL) -g root -o root -m 644 at_allow.5 $(IROOT)$(man5dir)/
-+ $(INSTALL) $(INSTALLOWN) -m 644 at_allow.5 $(IROOT)$(man5dir)/
- cd $(IROOT)$(man5dir) && $(LN_S) -f at_allow.5 at_deny.5
-- $(INSTALL) -g root -o root -m 644 $(DOCS) $(IROOT)$(atdocdir)
-+ $(INSTALL) $(INSTALLOWN) -m 644 $(DOCS) $(IROOT)$(atdocdir)
- rm -f $(IROOT)$(mandir)/cat1/at.1* $(IROOT)$(mandir)/cat1/batch.1* \
- $(IROOT)$(mandir)/cat1/atq.1*
- rm -f $(IROOT)$(mandir)/cat1/atd.8*
diff --git a/meta/recipes-extended/at/files/nonstripbinaries.patch b/meta/recipes-extended/at/files/nonstripbinaries.patch
new file mode 100644
index 0000000000..f89aa65576
--- /dev/null
+++ b/meta/recipes-extended/at/files/nonstripbinaries.patch
@@ -0,0 +1,25 @@
+#Because remove nonrootinstall patch, the stripping of the binaries can not
+#be handled.
+#This patch is to handle the stripping of the binaries.
+#Mei Lei<lei.mei@intel.com> make this change
+diff --git a/build/downloads/at-3.1.12/Makefile.in b/build/downloads/at-3.1.12/Makefile.in
+index dae6b7d..71a5d89 100644
+--- a/build/downloads/at-3.1.12/Makefile.in
++++ b/build/downloads/at-3.1.12/Makefile.in
+@@ -97,14 +97,14 @@ install: all
+ chmod 600 $(IROOT)$(LFILE)
+ chown $(DAEMON_USERNAME):$(DAEMON_GROUPNAME) $(IROOT)$(LFILE)
+ test -f $(IROOT)$(etcdir)/at.allow || test -f $(IROOT)$(etcdir)/at.deny || $(INSTALL) -o root -g $(DAEMON_GROUPNAME) -m 640 at.deny $(IROOT)$(etcdir)/
+- $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 -s at $(IROOT)$(bindir)
++ $(INSTALL) -g $(DAEMON_GROUPNAME) -o $(DAEMON_USERNAME) -m 6755 at $(IROOT)$(bindir)
+ $(LN_S) -f at $(IROOT)$(bindir)/atq
+ $(LN_S) -f at $(IROOT)$(bindir)/atrm
+ $(INSTALL) -g root -o root -m 755 batch $(IROOT)$(bindir)
+ $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man1dir)
+ $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man5dir)
+ $(INSTALL) -d -o root -g root -m 755 $(IROOT)$(man8dir)
+- $(INSTALL) -g root -o root -m 755 -s atd $(IROOT)$(sbindir)
++ $(INSTALL) -g root -o root -m 755 atd $(IROOT)$(sbindir)
+ $(INSTALL) -g root -o root -m 755 atrun $(IROOT)$(sbindir)
+ $(INSTALL) -g root -o root -m 644 at.1 $(IROOT)$(man1dir)/
+ cd $(IROOT)$(man1dir) && $(LN_S) -f at.1 atq.1 && $(LN_S) -f at.1 batch.1 && $(LN_S) -f at.1 atrm.1