summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/baremetal-example
diff options
context:
space:
mode:
authorAlejandro Hernandez Samaniego <alejandro@enedino.org>2023-06-23 17:31:22 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-27 16:23:34 +0100
commit9a999af292c7b3dd3bb7c0722cc31624c425f432 (patch)
tree30bc6fa1448ba9b57855ac024c714e8e26fe88ef /meta/recipes-extended/baremetal-example
parent48b8945fa570edcdf1e19ed4a4ca81c4416f1a6a (diff)
downloadopenembedded-core-9a999af292c7b3dd3bb7c0722cc31624c425f432.tar.gz
baremetal-helloworld: Fix race condition
There was a race condition during the Makefile execution in between the assemble and compile targets, only the assemble target had a dependency on creating the build directory. If the compile target was executed first, an error was thrown by bitbake since the build directory did not exist yet: | Assembler messages: | Fatal error: can't create build/hello_baremetal_aarch64.o: No such file or directory Update the SRCREV to reflect the latest changes serializing the makefile targets to avoid such race condition from happening. [YOCTO #15146] Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro@enedino.org> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/baremetal-example')
-rw-r--r--meta/recipes-extended/baremetal-example/baremetal-helloworld_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/baremetal-example/baremetal-helloworld_git.bb b/meta/recipes-extended/baremetal-example/baremetal-helloworld_git.bb
index 4182372057..c5d3e04ed5 100644
--- a/meta/recipes-extended/baremetal-example/baremetal-helloworld_git.bb
+++ b/meta/recipes-extended/baremetal-example/baremetal-helloworld_git.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "These are introductory examples to showcase the use of QEMU to ru
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=39346640a23c701e4f459e05f56f4449"
-SRCREV = "ea7f59b02467ed1fb36c3b4c6d5cabe702df26ec"
+SRCREV = "fc7c43d138185028b6ac14c83f6492fce26eca95"
PV = "0.1+git${SRCPV}"
SRC_URI = "git://github.com/ahcbb6/baremetal-helloqemu.git;protocol=https;branch=master"