summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/go-examples
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2022-04-29 10:22:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-04-29 17:54:23 +0100
commit70bc5b6d40f94bde82415fb87db37fdf2606c2fb (patch)
tree5df6d0eb9cf3e604ba01d23e31a688347cbd55d2 /meta/recipes-extended/go-examples
parent51d7310b6cf8ef9033d461868c07f686656070ba (diff)
downloadopenembedded-core-70bc5b6d40f94bde82415fb87db37fdf2606c2fb.tar.gz
go-helloworld: remove unused GO_WORKDIR
The GO_WORKDIR is used only in go-mod.bbclass. As this recipe does not inherit go-mod.bbclass, this variable is useless here. This go-helloworld recipe was made to inherit go-mod.bbclass and build in module-aware mode. However, it was found that we need to build go recipes in GOPATH mode in order to support offline build. As a result, this recipe was changed back to only inherit go.bbclass. But the GO_WORKDIR setting was not cleaned up. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/go-examples')
-rw-r--r--meta/recipes-extended/go-examples/go-helloworld_0.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
index 0faab39b66..d0de035921 100644
--- a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
+++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
@@ -11,7 +11,7 @@ UPSTREAM_CHECK_COMMITS = "1"
GO_IMPORT = "golang.org/x/example"
GO_INSTALL = "${GO_IMPORT}/hello"
-GO_WORKDIR = "${GO_INSTALL}"
+
export GO111MODULE="off"
inherit go