summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2015-12-11 18:14:31 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-16 12:11:23 +0000
commitbd7efb42c04649de54d36401d2745d6a0aab96c3 (patch)
tree806ce0e5066bc216b682525dba56d04b0308d37c /meta/recipes-extended/libsolv
parent32076a55fec1f01f84fe84aefc9300fae25f2519 (diff)
downloadopenembedded-core-bd7efb42c04649de54d36401d2745d6a0aab96c3.tar.gz
libsolv: add new recipe
Required by the optional opkg 0.3.1 libsolv backend. Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/libsolv')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_git.bb b/meta/recipes-extended/libsolv/libsolv_git.bb
new file mode 100644
index 0000000000..2011487f50
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Library for solving packages and reading repositories"
+HOMEPAGE = "https://github.com/openSUSE/libsolv"
+BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
+SECTION = "devel"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
+
+DEPENDS = "expat zlib"
+
+PV = "0.6.14+git${SRCPV}"
+
+SRC_URI = "git://github.com/openSUSE/libsolv.git"
+SRCREV = "b1ea39233f86cd62fbab1964d7497244f6be0087"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "-DLIB=${baselib}"
+
+PACKAGES =+ "${PN}-tools ${PN}ext ${PN}ext-dbg"
+
+FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibSolv.cmake"
+FILES_${PN}-tools = "${bindir}/*"
+FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
+FILES_${PN}ext-dbg = "${libdir}/.debug/${PN}ext.so.*"
+
+BBCLASSEXTEND =+ "native nativesdk"