aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsbtest_1.0.bb
diff options
context:
space:
mode:
authorStefan Stanacar <stefanx.stanacar@intel.com>2014-03-11 15:40:09 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2014-03-12 19:00:34 +0000
commitabf46d03eff2288715b054057ac253eca61f8a63 (patch)
tree3190ce13fa4dcfbd632760b9655dc67205c2b60c /meta/recipes-extended/lsb/lsbtest_1.0.bb
parentc45acfae254004baa4011a35addf0e26a11d71bd (diff)
downloadopenembedded-core-abf46d03eff2288715b054057ac253eca61f8a63.tar.gz
lsbtest: fix comparison bashism
== is a bashism use = instead. (Based on OE-Core master rev: c90d1047c41148cbd57f26b5a34563346602a71b) Signed-off-by: Stefan Stanacar <stefanx.stanacar@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/lsb/lsbtest_1.0.bb')
-rw-r--r--meta/recipes-extended/lsb/lsbtest_1.0.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest_1.0.bb b/meta/recipes-extended/lsb/lsbtest_1.0.bb
index 8973e094e5..84cb4f2425 100644
--- a/meta/recipes-extended/lsb/lsbtest_1.0.bb
+++ b/meta/recipes-extended/lsb/lsbtest_1.0.bb
@@ -19,15 +19,15 @@ do_install() {
install -d ${D}/opt/lsb-test
install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
install -m 0644 ${S}/session ${D}/opt/lsb-test/session
- if [ "${TARGET_ARCH}" == "i586" ];then
+ if [ "${TARGET_ARCH}" = "i586" ];then
sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
fi
- if [ "${TARGET_ARCH}" == "x86_64" ];then
+ if [ "${TARGET_ARCH}" = "x86_64" ];then
sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session
fi
- if [ "${TARGET_ARCH}" == "powerpc" ];then
+ if [ "${TARGET_ARCH}" = "powerpc" ];then
sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
fi