aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man/man_1.6g.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-12-13 19:01:35 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-19 17:50:03 +0000
commit4cb22ea0beb952a5d70f83aaac415b7f2ecf3fd5 (patch)
treebda353cc607b4fffd680f19017f239e98563fe20 /meta/recipes-extended/man/man_1.6g.bb
parenta7fe871f7d5c1ac595df7a0e202f0e5d1fb76f03 (diff)
downloadopenembedded-core-4cb22ea0beb952a5d70f83aaac415b7f2ecf3fd5.tar.gz
man: Update to 1.6g
Rebase some patches Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/man/man_1.6g.bb')
-rw-r--r--meta/recipes-extended/man/man_1.6g.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-extended/man/man_1.6g.bb b/meta/recipes-extended/man/man_1.6g.bb
new file mode 100644
index 0000000000..a2d6acefa6
--- /dev/null
+++ b/meta/recipes-extended/man/man_1.6g.bb
@@ -0,0 +1,63 @@
+SUMMARY = "Online documentation tools"
+DESCRIPTION = "A set of documentation tools: man, apropos and whatis"
+SECTION = "console/utils"
+HOMEPAGE = "http://primates.ximian.com/~flucifredi/man"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
+
+PR = "r0"
+
+DEPENDS = "groff less"
+
+SRC_URI = "http://primates.ximian.com/~flucifredi/${BPN}/${BPN}-${PV}.tar.gz \
+ file://man-1.5k-confpath.patch;striplevel=0 \
+ file://man-1.5h1-make.patch; \
+ file://man-1.5k-nonascii.patch; \
+ file://man-1.6e-security.patch; \
+ file://man-1.6e-mandirs.patch; \
+ file://man-1.5m2-bug11621.patch; \
+ file://man-1.5k-sofix.patch; \
+ file://man-1.5m2-buildroot.patch; \
+ file://man-1.6e-ro_usr.patch; \
+ file://man-1.5i2-newline.patch;striplevel=0 \
+ file://man-1.5j-utf8.patch; \
+ file://man-1.5i2-overflow.patch; \
+ file://man-1.5j-nocache.patch; \
+ file://man-1.5i2-initial.patch; \
+ file://man-1.5h1-gencat.patch;striplevel=0 \
+ file://man-1.5g-nonrootbuild.patch; \
+ file://man-1.5m2-tv_fhs.patch;striplevel=0 \
+ file://man-1.5j-i18n.patch; \
+ file://man-1.6e-whatis2.patch; \
+ file://man-1.6e-use_i18n_vars_in_a_std_way.patch; \
+ file://man-1.5m2-no-color-for-printing.patch; \
+ file://man-1.5m2-sigpipe.patch; \
+ file://man-1.6e-i18n_whatis.patch; \
+ file://man-1.6e-new_sections.patch; \
+ file://man*"
+
+SRC_URI[md5sum] = "ba154d5796928b841c9c69f0ae376660"
+SRC_URI[sha256sum] = "ccdcb8c3f4e0080923d7e818f0e4a202db26c46415eaef361387c20995b8959f"
+
+do_configure () {
+ ${S}/configure -default -confdir /etc +sgid +fhs +lang all
+}
+
+
+fakeroot do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+do_install_append(){
+ mkdir -p ${D}${sysconfdir}
+ mkdir -p ${D}${datadir}/man/man5
+ mkdir -p ${D}${datadir}/man/man7
+ cp ${WORKDIR}/man.conf ${D}${sysconfdir}/man.config
+ cp ${WORKDIR}/man.1.gz ${D}${datadir}/man/man1/
+ cp ${WORKDIR}/man.7.gz ${D}${datadir}/man/man7/
+ cp ${WORKDIR}/manpath.5.gz ${D}${datadir}/man/man5/
+}
+
+
+RDEPENDS_${PN} = "less groff"
+FILES_${PN} += "${datadir}/locale ${sysconfdir}/man.config"