summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mc
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-06-26 16:33:01 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-05 15:26:20 +0100
commit6d0205576ef1e8a62c469b883dc0c962440469a7 (patch)
tree44fb442bacf2c2bd4a098af6cb195305163fd2e0 /meta/recipes-extended/mc
parent33c85b9463462897adbbd142bfcfa791342d3f46 (diff)
downloadopenembedded-core-6d0205576ef1e8a62c469b883dc0c962440469a7.tar.gz
mc: Don't remove libdir and split helpers into packages
It contains helper programs that are needed to make mc do the right actions for the various file formats it understands. The helpers are perl, python and shell scripts, split them out so the core mc does not try to pull in perl and python, it will still run without these helpers. [YOCTO #4432] Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/mc')
-rw-r--r--meta/recipes-extended/mc/mc_4.7.5.2.bb26
-rw-r--r--meta/recipes-extended/mc/mc_4.8.8.bb23
2 files changed, 46 insertions, 3 deletions
diff --git a/meta/recipes-extended/mc/mc_4.7.5.2.bb b/meta/recipes-extended/mc/mc_4.7.5.2.bb
index e7ccc77caf..52e4f401a3 100644
--- a/meta/recipes-extended/mc/mc_4.7.5.2.bb
+++ b/meta/recipes-extended/mc/mc_4.7.5.2.bb
@@ -20,6 +20,28 @@ EXTRA_OECONF = "--with-screen=ncurses --without-gpm-mouse --without-x --without-
FILES_${PN}-dbg += "${libexecdir}/mc/.debug/"
do_install_append () {
- sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
-
+ sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
+ sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*
}
+
+PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish"
+
+DESCRIPTION_${BPN}-helpers-perl = "Midnight Commander perl based helper scripts"
+FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
+ ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
+ ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
+ ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
+ ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
+ ${libexecdir}/mc/extfs.d/uzip"
+RDEPENDS_${BPN}-helpers-perl = "perl"
+
+DESCRIPTION_${BPN}-helpers-python = "Midnight Commander python based helper scripts"
+FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541"
+RDEPENDS_${BPN}-helpers-python = "python"
+
+DESCRIPTION_${BPN}-helpers = "Midnight Commander shell helper scripts"
+FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
+
+DESCRIPTION_${BPN}-fish = "Midnight Commander Fish scripts"
+FILES_${BPN}-fish = "${libexecdir}/mc/fish"
+
diff --git a/meta/recipes-extended/mc/mc_4.8.8.bb b/meta/recipes-extended/mc/mc_4.8.8.bb
index 20ae797999..94924adae7 100644
--- a/meta/recipes-extended/mc/mc_4.8.8.bb
+++ b/meta/recipes-extended/mc/mc_4.8.8.bb
@@ -19,5 +19,26 @@ FILES_${PN}-dbg += "${libexecdir}/mc/.debug/"
do_install_append () {
sed -i -e '1s,#!.*perl,#!${bindir}/env perl,' ${D}${libexecdir}/mc/extfs.d/*
- rm -rf ${D}${libdir}
+ sed -i -e '1s,#!.*python,#!${bindir}/env python,' ${D}${libexecdir}/mc/extfs.d/*
}
+
+PACKAGES =+ "${BPN}-helpers-perl ${BPN}-helpers-python ${BPN}-helpers ${BPN}-fish"
+
+DESCRIPTION_${BPN}-helpers-perl = "Midnight Commander perl based helper scripts"
+FILES_${BPN}-helpers-perl = "${libexecdir}/mc/extfs.d/a+ ${libexecdir}/mc/extfs.d/apt+ \
+ ${libexecdir}/mc/extfs.d/deb ${libexecdir}/mc/extfs.d/deba \
+ ${libexecdir}/mc/extfs.d/debd ${libexecdir}/mc/extfs.d/dpkg+ \
+ ${libexecdir}/mc/extfs.d/mailfs ${libexecdir}/mc/extfs.d/patchfs \
+ ${libexecdir}/mc/extfs.d/rpms+ ${libexecdir}/mc/extfs.d/ulib \
+ ${libexecdir}/mc/extfs.d/uzip"
+RDEPENDS_${BPN}-helpers-perl = "perl"
+
+DESCRIPTION_${BPN}-helpers-python = "Midnight Commander python based helper scripts"
+FILES_${BPN}-helpers-python = "${libexecdir}/mc/extfs.d/s3+ ${libexecdir}/mc/extfs.d/uc1541"
+RDEPENDS_${BPN}-helpers-python = "python"
+
+DESCRIPTION_${BPN}-helpers = "Midnight Commander shell helper scripts"
+FILES_${BPN}-helpers = "${libexecdir}/mc/extfs.d/* ${libexecdir}/mc/ext.d/*"
+
+DESCRIPTION_${BPN}-fish = "Midnight Commander Fish scripts"
+FILES_${BPN}-fish = "${libexecdir}/mc/fish"