summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-29 22:49:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-30 09:54:28 +0100
commitef7968dbded62cfce91e4f44bc96e8d04b076f15 (patch)
treeec1c756ad5c34458880084f997eb88286b270aa8 /meta/recipes-extended/packagegroups
parent5c7946f790b5e8da8f30e3493c04c07b30b89d17 (diff)
downloadopenembedded-core-ef7968dbded62cfce91e4f44bc96e8d04b076f15.tar.gz
packagegroup-core-lsb: Limit mips64 issues to qt4 packages only
The COMPATIBLE_HOST setting was only there for mips64 issues. Move that restriction to the qt4 packages themselves so the rest of the lsb images can be built. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/packagegroups')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb19
1 files changed, 11 insertions, 8 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
index 68070e4f02..914a7a9b7e 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -7,8 +7,6 @@ DESCRIPTION = "Packages required to satisfy the Linux Standard Base (LSB) specif
PR = "r10"
LICENSE = "MIT"
-COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
-
inherit packagegroup
PACKAGES = "\
@@ -203,23 +201,28 @@ def get_libqt3(d):
bb.warn('a requirement for LSB')
return ''
-SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
-DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
- specified in the LSB Desktop specification"
-RDEPENDS_packagegroup-core-lsb-desktop = "\
+QT4PKGS = " \
libqtcore4 \
libqtgui4 \
libqtsql4 \
libqtsvg4 \
libqtxml4 \
libqtnetwork4 \
+ qt4-plugin-sqldriver-sqlite \
+ ${@base_contains("DISTRO_FEATURES", "opengl", "libqtopengl4", "", d)} \
+ "
+QT4PKGS_mips64 = ""
+
+SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
+DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
+ specified in the LSB Desktop specification"
+RDEPENDS_packagegroup-core-lsb-desktop = "\
libxt \
libxxf86vm \
libdrm \
libglu \
libxi \
libxtst \
- qt4-plugin-sqldriver-sqlite \
libx11-locale \
xorg-minimal-fonts \
gdk-pixbuf-loader-ico \
@@ -230,7 +233,7 @@ RDEPENDS_packagegroup-core-lsb-desktop = "\
gtk+ \
atk \
libasound \
- ${@base_contains("DISTRO_FEATURES", "opengl", "libqtopengl4", "", d)} \
+ ${QT4PKGS} \
${@get_libqt3(d)} \
"