summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang
diff options
context:
space:
mode:
authorRoy.Li <rongqing.li@windriver.com>2012-07-31 15:30:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-31 11:50:10 +0100
commit8c6a9bd7b4fea62b5765caecad660d372379e412 (patch)
tree5ce731e14ebd8e5a158afd6141af0b66a9ac7ff2 /meta/recipes-extended/slang
parentf28f6267271edbbef16caec323e9ba76e2216723 (diff)
downloadopenembedded-core-8c6a9bd7b4fea62b5765caecad660d372379e412.tar.gz
slang: change char type to signed char in macros
[YOCTO 2726] The patch of converting char type to signed char is only applied to arm, in fact it should be applied to powerpc too since powerpc has the same assumption for char type. To x86 and mips, this patch has not impact. Signed-off-by: Roy.Li <rongqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/slang')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
index 7082611fbe..b624af8c9c 100644
--- a/meta/recipes-extended/slang/slang_2.2.4.bb
+++ b/meta/recipes-extended/slang/slang_2.2.4.bb
@@ -10,7 +10,7 @@ to recode S-Lang procedures in C if you need to."
HOMEPAGE = "http://www.jedsoft.org/slang/"
SECTION = "libs"
DEPENDS = "pcre"
-PR = "r10"
+PR = "r11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
@@ -19,8 +19,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v2.2/slang-${PV}.tar.bz2 \
file://rpathfix.patch \
file://fix-check-pcre.patch \
+ file://change-char-type-to-signed-char-in-macros.patch \
"
-SRC_URI_append_arm = " file://change-char-type-to-signed-char-in-macros.patch"
inherit autotools