summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/unzip
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-03-12 12:58:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-03-20 10:59:05 +0000
commit3e6654f7b7f8e0e18c8115513410ecb308a0ad5f (patch)
treec13da47ec1bba17c2acd555d4c01a424b73b36d2 /meta/recipes-extended/unzip
parent1a50cc5aeafff0d8ee6c4a41dd2770ecd31455f0 (diff)
downloadopenembedded-core-3e6654f7b7f8e0e18c8115513410ecb308a0ad5f.tar.gz
unzip: Add ALTERNATIVE configuration
Since busybox also provides the unzip command use the update-alternatives mechanism to address this. [YOCTO #7446] Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/unzip')
-rw-r--r--meta/recipes-extended/unzip/unzip_6.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-extended/unzip/unzip_6.0.bb b/meta/recipes-extended/unzip/unzip_6.0.bb
index 33c20f8b4c..e203c069f4 100644
--- a/meta/recipes-extended/unzip/unzip_6.0.bb
+++ b/meta/recipes-extended/unzip/unzip_6.0.bb
@@ -35,4 +35,11 @@ do_install() {
rmdir ${D}${prefix}/man/
}
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "100"
+
+ALTERNATIVE_${PN} = "unzip"
+ALTERNATIVE_LINK_NAME[unzip] = "${bindir}/unzip"
+
BBCLASSEXTEND = "native"