aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-03-23 08:37:50 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-03-23 17:47:34 +0000
commit046a236bf0e6005ccc8af7c1449a4fa2e1e9e91c (patch)
tree63540bcafa3950698bf2ad40101dec45fb636f07 /meta/recipes-extended
parent60f144d336b5c344e7004d3cbf4d0c3fc9e1a1f2 (diff)
downloadopenembedded-core-046a236bf0e6005ccc8af7c1449a4fa2e1e9e91c.tar.gz
libzypp: Fix buiild with gcc 4.7
it needs protype of close() before using it Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libzypp/libzypp/close.patch32
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb3
2 files changed, 34 insertions, 1 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp/close.patch b/meta/recipes-extended/libzypp/libzypp/close.patch
new file mode 100644
index 0000000000..0ff1825410
--- /dev/null
+++ b/meta/recipes-extended/libzypp/libzypp/close.patch
@@ -0,0 +1,32 @@
+close() is used without a protype therefore we include unistd.h
+Fixes compile errors like below
+
+/home/kraj/work/openembedded-core/build/tmp-eglibc/work/qemuppc-oe-linux/libzypp-0.0-git1+15b6c52260bbc52b3d8e585e271b67e10cc7c433-r18/git/zypp/ExternalProgram.h:239:47: error: '::close' has not been declared
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: git/zypp/ExternalProgram.h
+===================================================================
+--- git.orig/zypp/ExternalProgram.h 2012-03-23 08:27:31.716438539 -0700
++++ git/zypp/ExternalProgram.h 2012-03-23 08:27:54.520439367 -0700
+@@ -16,6 +16,7 @@
+ #include <map>
+ #include <string>
+ #include <vector>
++#include <unistd.h>
+
+ #include "zypp/base/ExternalDataSource.h"
+ #include "zypp/Pathname.h"
+Index: git/zypp/base/Random.cc
+===================================================================
+--- git.orig/zypp/base/Random.cc 2012-03-23 08:31:09.732449118 -0700
++++ git/zypp/base/Random.cc 2012-03-23 08:31:36.240450324 -0700
+@@ -3,6 +3,7 @@
+ #include <cstdio>
+ #include <iostream>
+ #include <fcntl.h>
++#include <unistd.h>
+ #include "zypp/base/Random.h"
+
+ using namespace std;
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index 368cc06986..78c7a6a057 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -11,7 +11,7 @@ DEPENDS = "rpm boost curl libxml2 zlib sat-solver expat openssl udev"
S = "${WORKDIR}/git"
SRCREV = "15b6c52260bbc52b3d8e585e271b67e10cc7c433"
PV = "0.0-git${SRCPV}"
-PR = "r18"
+PR = "r19"
SRC_URI = "git://github.com/openSUSE/libzypp.git;protocol=git \
file://no-doc.patch \
@@ -22,6 +22,7 @@ SRC_URI = "git://github.com/openSUSE/libzypp.git;protocol=git \
file://libzypp-compatargs.patch \
file://fix_for_compile_wth_gcc-4.6.0.patch \
file://hardcode-lib-fix.patch \
+ file://close.patch \
"
SRC_URI_append_mips = " file://mips-workaround-gcc-tribool-error.patch"