aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-01-22 12:55:34 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-28 00:48:25 +0000
commit06b6b29a526541acde8916d6ba504655f4401f37 (patch)
treef37b953bafdcfd0761fba1b50c76c2d0e4724ebc /meta/recipes-extended
parent0b49729af46f98a1bd155fc798d39d5d12c674cd (diff)
downloadopenembedded-core-06b6b29a526541acde8916d6ba504655f4401f37.tar.gz
gawk: enable ptest support
Install gawk test suite and run it as ptest. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/gawk/gawk-4.0.2/run-ptest10
-rw-r--r--meta/recipes-extended/gawk/gawk_4.0.2.bb13
2 files changed, 22 insertions, 1 deletions
diff --git a/meta/recipes-extended/gawk/gawk-4.0.2/run-ptest b/meta/recipes-extended/gawk/gawk-4.0.2/run-ptest
new file mode 100644
index 0000000000..7d214eafbe
--- /dev/null
+++ b/meta/recipes-extended/gawk/gawk-4.0.2/run-ptest
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+cd test
+for i in `grep -vE "@|^$|#|Gt-dummy" Maketests |awk -F: '{print $1}'`; \
+ do LC_ALL=${GAWKLOCALE:-C} LANG=${GAWKLOCALE:-C} srcdir=`pwd` AWK=gawk CMP=cmp \
+ make -f Maketests $i &>$i.tmp; \
+ grep -q "Error" $i.tmp; \
+ if [ $? == 0 ]; then echo "FAIL: $i"; \
+ else echo "PASS: $i"; rm -f $i.tmp; fi; \
+done
diff --git a/meta/recipes-extended/gawk/gawk_4.0.2.bb b/meta/recipes-extended/gawk/gawk_4.0.2.bb
index 424b6b0077..eb86af39da 100644
--- a/meta/recipes-extended/gawk/gawk_4.0.2.bb
+++ b/meta/recipes-extended/gawk/gawk_4.0.2.bb
@@ -16,7 +16,9 @@ DEPENDS += "readline"
RDEPENDS_gawk += "gawk-common"
RDEPENDS_pgawk += "gawk-common"
-SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz"
+SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz \
+ file://run-ptest \
+"
SRC_URI[md5sum] = "4d505dc2c9f1eb3e9f8d6cac87d4bd1a"
SRC_URI[sha256sum] = "6e0de117c3713aa8d7fa347fc9fd645b10038ae49d8cf947d8c1d51cbb76141a"
@@ -39,3 +41,12 @@ do_install_append() {
# remove the link since we don't package it
rm ${D}${bindir}/awk
}
+
+inherit ptest
+
+do_install_ptest() {
+ mkdir ${D}${PTEST_PATH}/test
+ for i in `grep -vE "@|^$|#|Gt-dummy" ${S}/test/Maketests |awk -F: '{print $1}'` Maketests; \
+ do cp ${S}/test/$i* ${D}${PTEST_PATH}/test; \
+ done
+}