aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-04-17 15:02:11 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-17 23:15:46 +0100
commiteddb1d6f458bcf8b0473a360fad3f4a259a57d28 (patch)
treef07efc4a1f64f4c08d95e314871569ee4af975af /meta/recipes-extended
parent1f68d624c109c3f31a6f2f6106b5ef56e3d9a166 (diff)
downloadopenembedded-core-eddb1d6f458bcf8b0473a360fad3f4a259a57d28.tar.gz
lsb: Add DISTRO Info to /etc/lsb-release file also add util-linux to DEPENDS
Add the DISTRO* fields to the /etc/lsb-release file so the distro parsing code can find standard information about the Poky Distro when using the Self-Hosted Image. The lsb_release command uses getopt which is provided by util-linux Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/lsb/lsb_1.4.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsb/lsb_1.4.bb b/meta/recipes-extended/lsb/lsb_1.4.bb
index f2f25ba639..e414d93260 100644
--- a/meta/recipes-extended/lsb/lsb_1.4.bb
+++ b/meta/recipes-extended/lsb/lsb_1.4.bb
@@ -4,6 +4,8 @@ HOMEPAGE = "http://prdownloads.sourceforge.net/lsb"
LICENSE = "GPLv2+"
PR = "r2"
+DEPENDS="util-linux"
+
LIC_FILES_CHKSUM = "file://README;md5=12da544b1a3a5a1795a21160b49471cf"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/lsb/lsb_release/${PV}/lsb-release-${PV}.tar.gz \
@@ -31,6 +33,9 @@ do_install(){
echo -n "core-4.1-${TARGET_ARCH}" >> ${D}/etc/lsb-release
fi
echo "\"" >> ${D}/etc/lsb-release
+ echo "DISTRIB_ID=${DISTRO}" >> ${D}/etc/lsb-release
+ echo "DISTRIB_RELEASE=${DISTRO_VERSION}" >> ${D}/etc/lsb-release
+ echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}/etc/lsb-release
if [ "${TARGET_ARCH}" == "i586" ];then
mkdir -p ${D}/etc/lsb-release.d