summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2010-12-23 20:23:33 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-12-30 10:03:10 +0000
commit0e8f0f0a033c79611a15914fde5826876502af2e (patch)
tree6eaed12c3fbab03d9adf193e923b6e20e2937f0d /meta/recipes-extended
parent35e3443b57d009bffd8904c7c6c3a4769193c1b4 (diff)
downloadopenembedded-core-0e8f0f0a033c79611a15914fde5826876502af2e.tar.gz
RDEPENDS, RRECOMMENDS -> RDPEPENDS_${PN}, RRECOMMENDS_${PN}
For these recipes the dependencies listed in RDEPENDS and RRECOMMENDS only apply to ${PN} Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/libzypp/libzypp_git.bb4
-rw-r--r--meta/recipes-extended/man-pages/man-pages_3.25.bb4
-rw-r--r--meta/recipes-extended/mc/mc_4.7.3.bb4
-rw-r--r--meta/recipes-extended/polkit/polkit_0.99.bb4
-rw-r--r--meta/recipes-extended/shadow/shadow.inc2
-rw-r--r--meta/recipes-extended/shadow/shadow_4.1.4.2.bb2
-rw-r--r--meta/recipes-extended/zypper/zypper_git.bb4
7 files changed, 13 insertions, 11 deletions
diff --git a/meta/recipes-extended/libzypp/libzypp_git.bb b/meta/recipes-extended/libzypp/libzypp_git.bb
index e29556925a..6918263296 100644
--- a/meta/recipes-extended/libzypp/libzypp_git.bb
+++ b/meta/recipes-extended/libzypp/libzypp_git.bb
@@ -9,11 +9,11 @@ inherit cmake
DEPENDS = "rpm boost gettext curl libxml2 zlib sat-solver expat openssl udev"
# rpmdb2solv from sat-solver is run from libzypp
-RDEPENDS = "sat-solver"
+RDEPENDS_${PN} = "sat-solver"
S = "${WORKDIR}/git"
PV = "0.0-git${SRCPV}"
-PR = "r3"
+PR = "r4"
SRC_URI = "git://gitorious.org/opensuse/libzypp.git;protocol=git \
file://no-doc.patch \
diff --git a/meta/recipes-extended/man-pages/man-pages_3.25.bb b/meta/recipes-extended/man-pages/man-pages_3.25.bb
index b5b200c98a..358f78dc76 100644
--- a/meta/recipes-extended/man-pages/man-pages_3.25.bb
+++ b/meta/recipes-extended/man-pages/man-pages_3.25.bb
@@ -4,7 +4,7 @@ SECTION = "console/utils"
PRIORITY = "required"
HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
LIC_FILES_CHKSUM = "file://README;md5=9dab010c5baa416669e5d17381799dd5"
SRC_URI = "http://www.kernel.org/pub/linux/docs/man-pages/Archive/${PN}-${PV}.tar.gz"
@@ -12,7 +12,7 @@ SRC_URI = "http://www.kernel.org/pub/linux/docs/man-pages/Archive/${PN}-${PV}.ta
SRC_URI[md5sum] = "98ec2324abea77d7a992470dd44d140c"
SRC_URI[sha256sum] = "474242842a78dc2121687b7db6c32b6c78af5458f2bd809e23563dd185e2b169"
-RDEPENDS = "man"
+RDEPENDS_${PN} = "man"
do_configure_prepend() {
rm -rf not_installed
diff --git a/meta/recipes-extended/mc/mc_4.7.3.bb b/meta/recipes-extended/mc/mc_4.7.3.bb
index 22a1a9397d..537aa05e37 100644
--- a/meta/recipes-extended/mc/mc_4.7.3.bb
+++ b/meta/recipes-extended/mc/mc_4.7.3.bb
@@ -4,7 +4,9 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
SECTION = "console/utils"
DEPENDS = "ncurses glib-2.0"
-RDEPENDS = "ncurses-terminfo"
+RDEPENDS_${PN} = "ncurses-terminfo"
+
+PR = "r1"
SRC_URI = "http://www.midnight-commander.org/downloads/${PN}-${PV}.tar.bz2"
diff --git a/meta/recipes-extended/polkit/polkit_0.99.bb b/meta/recipes-extended/polkit/polkit_0.99.bb
index f578ccad6b..7f969792ea 100644
--- a/meta/recipes-extended/polkit/polkit_0.99.bb
+++ b/meta/recipes-extended/polkit/polkit_0.99.bb
@@ -7,9 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
file://docs/polkit/html/license.html;md5=54750ec6ece444c50b823234d445dd99"
SRC_URI = "http://hal.freedesktop.org/releases/polkit-${PV}.tar.gz"
-PR = "r0"
+PR = "r1"
DEPENDS = "libpam expat dbus-glib eggdbus intltool"
-RDEPENDS = "libpam"
+RDEPENDS_${PN} = "libpam"
EXTRA_OECONF = "--with-authfw=pam --with-os-type=moblin --disable-man-pages --disable-gtk-doc --disable-introspection"
inherit autotools pkgconfig
diff --git a/meta/recipes-extended/shadow/shadow.inc b/meta/recipes-extended/shadow/shadow.inc
index fcbcb3eb75..42f92a7f4e 100644
--- a/meta/recipes-extended/shadow/shadow.inc
+++ b/meta/recipes-extended/shadow/shadow.inc
@@ -20,7 +20,7 @@ PAM_PLUGINS = " libpam-runtime \
pam-plugin-rootok"
DEPENDS = "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
-RDEPENDS = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_PLUGINS}', '', d)}"
+RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_PLUGINS}', '', d)}"
# since we deduce from ${SERIAL_CONSOLE}
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta/recipes-extended/shadow/shadow_4.1.4.2.bb b/meta/recipes-extended/shadow/shadow_4.1.4.2.bb
index ca5f533f92..224ae5e38f 100644
--- a/meta/recipes-extended/shadow/shadow_4.1.4.2.bb
+++ b/meta/recipes-extended/shadow/shadow_4.1.4.2.bb
@@ -1,6 +1,6 @@
require shadow.inc
-PR = "r0"
+PR = "r1"
SRC_URI += "file://shadow.automake-1.11.patch \
file://shadow-4.1.3-dots-in-usernames.patch \
diff --git a/meta/recipes-extended/zypper/zypper_git.bb b/meta/recipes-extended/zypper/zypper_git.bb
index 8caf4db39e..c8895e5806 100644
--- a/meta/recipes-extended/zypper/zypper_git.bb
+++ b/meta/recipes-extended/zypper/zypper_git.bb
@@ -5,8 +5,8 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=3201406e350b39e05a82e28b5020f413"
DEPENDS = "libzypp augeas"
-RRECOMMENDS = "procps"
-PR = "r1"
+RRECOMMENDS_${PN} = "procps"
+PR = "r2"
inherit cmake