summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorHaiqing Bai <Haiqing.Bai@windriver.com>2018-01-22 16:46:10 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-22 23:25:47 +0000
commit8023052653d44a8bbd3618ba700aa260e581036e (patch)
tree9a6d5b1d25b36223d42600b4d7651b7a76fea2d4 /meta/recipes-extended
parent712d7acd5dada55f980d46788e8dd129570a9d61 (diff)
downloadopenembedded-core-8023052653d44a8bbd3618ba700aa260e581036e.tar.gz
grep: support Perl regular expression
Supporting Perl regular expression is disabled with '--disable-perl-regexp' but the manpage of 'grep' shows the '-P' option and returns below error: "/bin/grep.grep -o -P 'PATTERN' file /bin/grep.grep: support for the -P option is not compiled into this \ --disable-perl-regexp binary" Signed-off-by: Haiqing Bai <Haiqing.Bai@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/grep/grep_3.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-extended/grep/grep_3.1.bb b/meta/recipes-extended/grep/grep_3.1.bb
index 05b6b93949..71810dc655 100644
--- a/meta/recipes-extended/grep/grep_3.1.bb
+++ b/meta/recipes-extended/grep/grep_3.1.bb
@@ -14,8 +14,6 @@ SRC_URI[sha256sum] = "db625c7ab3bb3ee757b3926a5cfa8d9e1c3991ad24707a83dde8a5ef2b
inherit autotools gettext texinfo pkgconfig
-EXTRA_OECONF = "--disable-perl-regexp"
-
# Fix "Argument list too long" error when len(TMPDIR) = 410
acpaths = "-I ./m4"
@@ -36,6 +34,9 @@ do_install () {
inherit update-alternatives
+PACKAGECONFIG ??= "pcre"
+PACKAGECONFIG[pcre] = "--enable-perl-regexp,--disable-perl-regexp,libpcre"
+
ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_${PN} = "grep egrep fgrep"