aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-09-04 23:56:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-09 12:12:17 +0100
commitd3c48ff7d19e86b2338b1778f9563969bba3d336 (patch)
treeeed9609d3f9399b2ebf02c425c215fef99bcc8d5 /meta/recipes-gnome
parent54afc564cd13dc6b73a65ced9545d5d37d85f6a1 (diff)
downloadopenembedded-core-d3c48ff7d19e86b2338b1778f9563969bba3d336.tar.gz
gobject-introspection: set GI_SCANNER_DISABLE_CACHE for native
The native recipe should not write files to $HOME/.cache as target, this can avoid problems when multi builds are running on the same host like: | File "./g-ir-scanner", line 66, in <module> | sys.exit(scanner_main(sys.argv)) | File "../gobject-introspection-1.48.0/giscanner/scannermain.py", line 543, in scanner_main | transformer = create_transformer(namespace, options) | File "../gobject-introspection-1.48.0/giscanner/scannermain.py", line 389, in create_transformer | symbol_filter_cmd=options.symbol_filter_cmd) | File "../gobject-introspection-1.48.0/giscanner/transformer.py", line 54, in __init__ | self._cachestore = CacheStore() | File "../gobject-introspection-1.48.0/giscanner/cachestore.py", line 61, in __init__ | self._check_cache_version() | File "../gobject-introspection-1.48.0/giscanner/cachestore.py", line 89, in _check_cache_version | self._clean() | File "../gobject-introspection-1.48.0/giscanner/cachestore.py", line 141, in _clean | self._remove_filename(os.path.join(self._directory, filename)) | File "../gobject-introspection-1.48.0/giscanner/cachestore.py", line 123, in _remove_filename | os.unlink(filename) | FileNotFoundError: [Errno 2] No such file or directory: '/home/pokybuild/.cache/g-ir-scanner/0a47aa95823c95a0b5d1bd610b60d02f35785f26' | Makefile:3518: recipe for target 'GModule-2.0.gir' failed Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
index b41a317099..abaa485798 100644
--- a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
+++ b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.48.0.bb
@@ -107,7 +107,7 @@ EXTRA_OECONF_class-target += "--enable-host-gi \
PACKAGECONFIG ?= ""
PACKAGECONFIG[doctool] = "--enable-doctool,--disable-doctool,python3-mako,"
-do_compile_prepend_class-target() {
+do_compile_prepend() {
# This prevents g-ir-scanner from writing cache data to $HOME
export GI_SCANNER_DISABLE_CACHE=1