aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2013-06-20 11:54:56 +1000
committerSaul Wold <sgw@linux.intel.com>2013-06-27 09:49:14 -0700
commitd860ee68208b84efb8049669ca18acc69f2f2d1b (patch)
tree1616dae045ccfbb0302e20d8fb529c9a52dd0a67 /meta/recipes-graphics
parent2f209a7045a93e7e42f90418a42f464827b4a7f8 (diff)
downloadopenembedded-core-d860ee68208b84efb8049669ca18acc69f2f2d1b.tar.gz
libx11: enable Xcms by default
The following do not work if Xcms is not enabled in libx11: - starting xterm and doing ls --color / fails to color code the directories: xterm: Cannot allocate color "rgb:5c/5c/ff" - xsetroot -solid rgb:5c/5c/ff fails with the following error: xsetroot: unknown color "rgb:5c/5c/ff" - xsetroot -solid rgbi:1.0/1.0/1.0 fails with the following error: xsetroot: unknown color "rgbi:1.0/1.0/1.0" More specifically, applications that pass Xcms color names to XParseColor do not work properly. [YOCTO #4576] Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb2
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11.inc4
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb b/meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb
index 0a90f463be..0b50f094a3 100644
--- a/meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb
+++ b/meta/recipes-graphics/xorg-lib/libx11-diet_1.5.0.bb
@@ -18,3 +18,5 @@ SRC_URI[md5sum] = "78b4b3bab4acbdf0abcfca30a8c70cc6"
SRC_URI[sha256sum] = "c382efd7e92bfc3cef39a4b7f1ecf2744ba4414a705e3bc1e697f75502bd4d86"
EXTRA_OECONF += "--disable-xlocale"
+
+PACKAGECONFIG ??= ""
diff --git a/meta/recipes-graphics/xorg-lib/libx11.inc b/meta/recipes-graphics/xorg-lib/libx11.inc
index e0fce3eba2..b4eb7d8cc6 100644
--- a/meta/recipes-graphics/xorg-lib/libx11.inc
+++ b/meta/recipes-graphics/xorg-lib/libx11.inc
@@ -25,9 +25,7 @@ DEPENDS += "xproto-native"
EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont"
EXTRA_OEMAKE += 'CWARNFLAGS=""'
-# Let people with incredibly archaic requirements enable Xcms, but disable it by
-# default.
-PACKAGECONFIG ??= ""
+PACKAGECONFIG ??= "xcms"
PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms"
# src/util/makekeys is built natively but needs -D_GNU_SOURCE defined.