aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-16 16:02:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-27 11:26:56 +0000
commit762b3111f3124ee75404835da751fb95b8466fd4 (patch)
treeebf36c472f5ff59409b9d59d5707801946594c03 /meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb
parent2b19c74332c3899c84708946d749f88c4416cf73 (diff)
downloadopenembedded-core-762b3111f3124ee75404835da751fb95b8466fd4.tar.gz
cryptodev: update to 1.8
Drop 0001-ioctl.c-Fix-build-on-3.19.patch and 0002-Fix-tests-Makefile-usage-of-LDLIBS-vs.-LDFLAGS.patch, the code has been fixed upstream. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb b/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb
new file mode 100644
index 0000000000..c55577c661
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-linux_1.8.bb
@@ -0,0 +1,13 @@
+require cryptodev.inc
+
+SUMMARY = "A /dev/crypto device driver header file"
+
+do_compile[noexec] = "1"
+
+# Just install cryptodev.h which is the only header file needed to be exported
+do_install() {
+ install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
+}
+
+ALLOW_EMPTY_${PN} = "1"
+BBCLASSEXTEND = "native nativesdk"