summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-03-06 13:11:13 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-08 10:36:16 -0800
commit1ba624ec410b13da9645efe7bc72908195c08259 (patch)
tree62005c405e77f3b0865dc9e93c49606917ee1667 /meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
parentbde0254a52f0827e15cdc66b91bef7c8ab03ea76 (diff)
downloadopenembedded-core-1ba624ec410b13da9645efe7bc72908195c08259.tar.gz
linux-yocto/4.12: fix aufs compile warning
From: "Kexin(Casey) Chen" <Casey.Chen@windriver.com> Forward port linux-yocto-4.8's patch to fix the build warning. http://git.yoctoproject.org/cgit/cgit.cgi/linux-yocto-4.8/commit/?h=standard/base&id=7e0dd2f2b0971f0e3191e1ddc088e09eb9855567 fs/aufs/debug.h:95:19: warning: comparison of constant '0' with boolean expression is always false [-Wbool-compare] if (unlikely((e) < 0)) \ ^ fs/aufs/vdir.c:852:2: note: in expansion of macro 'AuTraceErr' AuTraceErr(!valid); ^~~~~~~~~~ In expansion of AuTraceErr(!valid), comparison of (!valid) and constant '0' always passes unlikely(x) false. function 'static int seek_vdir(struct file *file, struct dir_context *ctx)' is to find whether there is a valid vd_deblk following ctx->pos. return 1 means valid, 0 for not. Change to AuTraceErr(valid - 1) makes more sense. Signed-off-by: Kexin(Casey) Chen <Casey.Chen@windriver.com> Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
index a31c3559e9..722315e843 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
@@ -11,8 +11,8 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "ba4e0e2d358124def579da9ba5992f6dcb94eea8"
-SRCREV_meta ?= "19d815d5a34bfaad95d87cc097cef18b594daac8"
+SRCREV_machine ?= "7a02176b872012f95036453dfd2e12dc0c02a612"
+SRCREV_meta ?= "ca1bda8dfd3325db04dda19a531edeb66ac0d84b"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"