summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_4.12.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-03-27 11:03:15 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-28 14:21:18 +0100
commit80f6840baecb8b161f6443f3dd1af4e70b5e5221 (patch)
tree26f09df6dcf5242288c564cee83535a022c119f2 /meta/recipes-kernel/linux/linux-yocto_4.12.bb
parent607b443f2abb915d4d12d6483b26030734983288 (diff)
downloadopenembedded-core-80f6840baecb8b161f6443f3dd1af4e70b5e5221.tar.gz
linux-yocto/4.12: add ssl and utils native dependencies
Via the -stable updates, and other configuration changes the 4.12 kernel has the same dependency on openssl headers as 4.14+. So we add the same DEPENDS line that we already have in newer kernels to avoid the following error: | HOSTCC scripts/sign-file | build/tmp/work-shared/qemux86-64/kernel-source/scripts/sign-file.c:25:30: fatal error: openssl/opensslv.h: No such file or directory | compilation terminated. | scripts/Makefile.host:107: recipe for target 'scripts/sign-file' failed | make[3]: *** [scripts/sign-file] Error 1 | make[3]: *** Waiting for unfinished jobs.... Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_4.12.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.12.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.12.bb b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
index 830634211a..6c82505b47 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.12.bb
@@ -24,6 +24,8 @@ SRCREV_meta ?= "2feb169ba66721f3794bacd97c8360ad594ce133"
SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;name=machine;branch=${KBRANCH}; \
git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.12;destsuffix=${KMETA}"
+DEPENDS += "openssl-native util-linux-native"
+
LINUX_VERSION ?= "4.12.21"
PV = "${LINUX_VERSION}+git${SRCPV}"