summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/perf/perf.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-10-21 16:16:18 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-11-04 13:31:27 +0000
commit79bfd5515887e5faf315a581d98bda63899760da (patch)
tree41b65a4c304e4409a1a254b2e853588afd754b89 /meta/recipes-kernel/perf/perf.bb
parent9a35c61d2218e139aa4420ef25f8cf4a0c4c2cfc (diff)
downloadopenembedded-core-79bfd5515887e5faf315a581d98bda63899760da.tar.gz
perf: drop 'include' copy
The copy of the kernel's top level include directory is not required to build perf. We have both the linux-libc-headers and perf's captured/copied headers for what it requires. The copy of the kernel's headers is leading us to multiple smaller fixes to ensure that the various .h files are in sync. We can remove the copy and all of the sync checks, and perf still builds and executes correctly. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/perf/perf.bb')
-rw-r--r--meta/recipes-kernel/perf/perf.bb9
1 files changed, 0 insertions, 9 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 191305969c..5f0ba7c180 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -106,7 +106,6 @@ EXTRA_OEMAKE += "\
EXTRA_OEMAKE_append_task-configure = " JOBS=1"
PERF_SRC ?= "Makefile \
- include \
tools/arch \
tools/build \
tools/include \
@@ -248,14 +247,6 @@ do_configure_prepend () {
# so we copy it from the sysroot unistd.h to the perf unistd.h
install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/tools/include/uapi/asm-generic/unistd.h
install -D -m0644 ${STAGING_INCDIR}/asm-generic/unistd.h ${S}/include/uapi/asm-generic/unistd.h
-
- # bits.h can have the same issue as unistd.h, so we make the tools variant take precedence
- [ -e ${S}/tools/include/linux/bits.h ] && install -D -m0644 ${S}/tools/include/linux/bits.h ${S}/include/linux/bits.h
-
- [ -e ${S}/tools/perf/util/include/linux/ctype.h ] && install -D -m0644 ${S}/include/linux/ctype.h ${S}/tools/perf/util/include/linux/ctype.h
-
- [ -e ${S}/include/uapi/linux/kvm.h ] && install -D -m0644 ${S}/include/uapi/linux/kvm.h ${S}/tools/include/uapi/linux/kvm.h
- [ -e ${S}/include/uapi/linux/sched.h ] && install -D -m0644 ${S}/include/uapi/linux/sched.h ${S}/tools/include/uapi/linux/sched.h
}
python do_package_prepend() {