summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorHenrik Nymann Jensen (HNJE) <hnje@triax.com>2019-03-29 19:14:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-04-01 14:58:15 +0100
commit95bc738e7f10d492f5db33fc581e9796e52a9d3f (patch)
treeb12c4903a34900b5980ca43fa8658aa5aec63cdf /meta/recipes-kernel
parent7c7d8ce6fe54e239374a6a04c007b4aa0712ba33 (diff)
downloadopenembedded-core-95bc738e7f10d492f5db33fc581e9796e52a9d3f.tar.gz
kernel-devsrc: fix /usr/src/kernel symlink to also work for SDK
If kernel-devsrc is used in a SDK context, the symlink from usr/src/kernel points to an absolute path '/lib/modules/${KERNEL_VERSION}/build', which ends up pointing to the local machine's build directory. To address this issue change the symlink to be realtive to ${D}/lib/modules/${KERNEL_VERSION}/build. Signed-off-by: Henrik Nymann Jensen <hnje@triax.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index 6daeea4f7a..69a8eaef81 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -48,7 +48,7 @@ do_install() {
mkdir -p ${D}/usr/src
(
cd ${D}/usr/src
- ln -s ${KERNEL_BUILD_ROOT}${KERNEL_VERSION}/source kernel
+ lnr ${D}${KERNEL_BUILD_ROOT}${KERNEL_VERSION}/source kernel
)
# for on target purposes, we unify build and source