summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2021-08-26 12:56:26 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-27 11:53:23 +0100
commitde0aa1700ed4e6f04b0a233eb1f6d2ac598e7ed8 (patch)
tree889120e5b2a9e8784e24177f77115b989c835258 /meta/recipes-kernel
parent56428d15803733e14d6f1faf5f77eb933ef966f3 (diff)
downloadopenembedded-core-de0aa1700ed4e6f04b0a233eb1f6d2ac598e7ed8.tar.gz
lttng-modules: do not search in non-existing folder during install
When CONFIG_TRACEPOINTS is not enabled in kernel config - module compilation is skipped, which causes the ${D}/${nonarch_base_libdir} not to be created. This fails later in do_install:append() due to the fact that find command in executed for non-existing folder. Check for folder existence before find command in executed. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.13.0.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.0.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.0.bb
index 109f5d6933..72d912eaf6 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.13.0.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.0.bb
@@ -23,7 +23,9 @@ MODULES_MODULE_SYMVERS_LOCATION = "src"
do_install:append() {
# Delete empty directories to avoid QA failures if no modules were built
- find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
+ if [ -d ${D}/${nonarch_base_libdir} ]; then
+ find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
+ fi
}
python do_package:prepend() {