summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-11-18 17:28:59 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-22 12:18:41 +0000
commite137ca045d21476394b12725447affe4c99b8e03 (patch)
tree90d07b7148ba161db8f5e0b2ab9fe5a68857756a /meta/recipes-kernel
parenta3417ce85e38d514c7dc43c2ddcdacf45996fc2a (diff)
downloadopenembedded-core-e137ca045d21476394b12725447affe4c99b8e03.tar.gz
linux-yocto/5.19: fix elfutils run-backtrace-native-core ptest failure
The following commit was integrated into the 5.19.15 -stable series and breaks the elfutils backtrace ptests. don't use __kernel_write() on kmap_local_page() It could be that other commits are also required in -stable, but a revert is the easiest way to deal with the regression. We can revisit newer kernel's (where the commit is also present) if they also start to fail the test. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.19.bb20
3 files changed, 12 insertions, 12 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb
index 5c316dbaf3..de087eabd4 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_5.19.bb
@@ -11,7 +11,7 @@ python () {
raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
}
-SRCREV_machine ?= "2bd6711a4dcc49e51ae68152ed0b40384e291554"
+SRCREV_machine ?= "7883e2f6464fb14e4652769c0294b2eef8075f5f"
SRCREV_meta ?= "0cba9aa40445bf59bfa651e1bd43a31c2ca7d524"
SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb
index 27fa6d9867..20ee864401 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.19.bb
@@ -14,7 +14,7 @@ DEPENDS += "openssl-native util-linux-native"
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
-SRCREV_machine ?= "ccb5f0a475b228c995800cb1b0f714426c2f1ec8"
+SRCREV_machine ?= "aaf4490d1807c49e3e0ceab1372533937ef2c82b"
SRCREV_meta ?= "0cba9aa40445bf59bfa651e1bd43a31c2ca7d524"
PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.19.bb b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
index 44bb02b9c1..8d891fe01c 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.19.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.19.bb
@@ -13,16 +13,16 @@ KBRANCH:qemux86 ?= "v5.19/standard/base"
KBRANCH:qemux86-64 ?= "v5.19/standard/base"
KBRANCH:qemumips64 ?= "v5.19/standard/mti-malta64"
-SRCREV_machine:qemuarm ?= "dfb2a8b83c0e37732dd930330132b692409f7321"
-SRCREV_machine:qemuarm64 ?= "ccb5f0a475b228c995800cb1b0f714426c2f1ec8"
-SRCREV_machine:qemumips ?= "b0e7e098c3fc9f2309e74137de4b8a5fcbaa2779"
-SRCREV_machine:qemuppc ?= "ccb5f0a475b228c995800cb1b0f714426c2f1ec8"
-SRCREV_machine:qemuriscv64 ?= "ccb5f0a475b228c995800cb1b0f714426c2f1ec8"
-SRCREV_machine:qemuriscv32 ?= "ccb5f0a475b228c995800cb1b0f714426c2f1ec8"
-SRCREV_machine:qemux86 ?= "ccb5f0a475b228c995800cb1b0f714426c2f1ec8"
-SRCREV_machine:qemux86-64 ?= "ccb5f0a475b228c995800cb1b0f714426c2f1ec8"
-SRCREV_machine:qemumips64 ?= "20d5adcd760ffdc90b4e5babb85a07b9d6ff3113"
-SRCREV_machine ?= "ccb5f0a475b228c995800cb1b0f714426c2f1ec8"
+SRCREV_machine:qemuarm ?= "dee954e39057710f00e5b3ea23514d01f3a4d940"
+SRCREV_machine:qemuarm64 ?= "aaf4490d1807c49e3e0ceab1372533937ef2c82b"
+SRCREV_machine:qemumips ?= "fe2b95c83e022371019027da3dd068ab33576d3f"
+SRCREV_machine:qemuppc ?= "aaf4490d1807c49e3e0ceab1372533937ef2c82b"
+SRCREV_machine:qemuriscv64 ?= "aaf4490d1807c49e3e0ceab1372533937ef2c82b"
+SRCREV_machine:qemuriscv32 ?= "aaf4490d1807c49e3e0ceab1372533937ef2c82b"
+SRCREV_machine:qemux86 ?= "aaf4490d1807c49e3e0ceab1372533937ef2c82b"
+SRCREV_machine:qemux86-64 ?= "aaf4490d1807c49e3e0ceab1372533937ef2c82b"
+SRCREV_machine:qemumips64 ?= "a5f29b9c64f2b3b47f74fee38f298d8a6b17a8b3"
+SRCREV_machine ?= "aaf4490d1807c49e3e0ceab1372533937ef2c82b"
SRCREV_meta ?= "0cba9aa40445bf59bfa651e1bd43a31c2ca7d524"
# set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll