summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/x264
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2018-02-02 15:33:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 10:54:39 +0000
commit85deeb7bdd17c417e48e86647ad1580e71829afa (patch)
tree28c2e2e931db948afb9c8361bfc3e9369ac5dba2 /meta/recipes-multimedia/x264
parent89a1c8c2e6393ed1f5f667036845b752d5277beb (diff)
downloadopenembedded-core-85deeb7bdd17c417e48e86647ad1580e71829afa.tar.gz
x264: upgrade to latest revision
Change dependency from yasm to nasm following this change: commit d2b5f4873e2147452a723b61b14f030b2ee760a5 Author: Henrik Gramner <henrik@gramner.com> Date: Sat Mar 18 18:50:36 2017 +0100 x86: Change assembler from yasm to nasm Refreshed the following patch: don-t-default-to-cortex-a9-with-neon.patch Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/x264')
-rw-r--r--meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch29
-rw-r--r--meta/recipes-multimedia/x264/x264_git.bb6
2 files changed, 24 insertions, 11 deletions
diff --git a/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch b/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
index 73f2aac613..065e3b35b7 100644
--- a/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
+++ b/meta/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
@@ -1,20 +1,33 @@
--march flag is not in CFLAGS so this will always default to -mcpu=cortex-a8
--mfpu=neon.
+From a72bf499a0674fc75eedf15008b424e28f67e4bd Mon Sep 17 00:00:00 2001
+From: Andrei Gherzan <andrei@gherzan.ro>
+Date: Fri, 2 Feb 2018 15:10:08 +0200
+Subject: [PATCH] dont default to cortex-a9 with neon
+
+-march flag is not in CFLAGS so this will always default to
+ -mcpu=cortex-a8 -mfpu=neon.
Upstream-Status: Pending
+
Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+Signed-off-by: Maxin B. John <maxin.john@intel.com>
+---
+ configure | 3 ---
+ 1 file changed, 3 deletions(-)
diff --git a/configure b/configure
-index 9d1586c..3109ec4 100755
+index 0e3ef23..955b993 100755
--- a/configure
+++ b/configure
-@@ -874,9 +874,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \) ] ; then
+@@ -911,9 +911,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \) ] ; then
fi
if [ $asm = auto -a $ARCH = ARM ] ; then
- # set flags so neon is built by default
-- echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu)' || CFLAGS="$CFLAGS -mcpu=cortex-a8 -mfpu=neon"
+- [ $compiler == CL ] || echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu)' || CFLAGS="$CFLAGS -mcpu=cortex-a8 -mfpu=neon"
-
- if cc_check '' '' '__asm__("rev ip, ip");' ; then define HAVE_ARMV6
- cc_check '' '' '__asm__("movt r0, #0");' && define HAVE_ARMV6T2
- cc_check '' '' '__asm__("vadd.i16 q0, q0, q0");' && define HAVE_NEON
+ cc_check '' '' '__asm__("add r0, r1, r2");' && define HAVE_ARM_INLINE_ASM
+ if [ $compiler = CL ] && cpp_check '' '' 'defined(_M_ARM) && _M_ARM >= 7' ; then
+ define HAVE_ARMV6
+--
+2.4.0
+
diff --git a/meta/recipes-multimedia/x264/x264_git.bb b/meta/recipes-multimedia/x264/x264_git.bb
index bc9775ab2a..a669295044 100644
--- a/meta/recipes-multimedia/x264/x264_git.bb
+++ b/meta/recipes-multimedia/x264/x264_git.bb
@@ -6,7 +6,7 @@ LICENSE = "GPLv2"
LICENSE_FLAGS = "commercial"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-DEPENDS = "yasm-native"
+DEPENDS = "nasm-native"
SRC_URI = "git://github.com/mirror/x264;branch=stable \
file://don-t-default-to-cortex-a9-with-neon.patch \
@@ -14,9 +14,9 @@ SRC_URI = "git://github.com/mirror/x264;branch=stable \
"
UPSTREAM_CHECK_COMMITS = "1"
-SRCREV = "2b741f81e51f92d053d87a49f59ff1026553a0f6"
+SRCREV = "e9a5903edf8ca59ef20e6f4894c196f135af735e"
-PV = "r2731+git${SRCPV}"
+PV = "r2854+git${SRCPV}"
S = "${WORKDIR}/git"