aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt-apps
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-05-11 00:06:16 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-16 07:33:15 +0100
commit2cf6e7cf81c0b864b5d51be60094a6eb3e584383 (patch)
treee4bb898d1b07c86cead2e7d9b67e43bfbe53a169 /meta/recipes-qt/qt-apps
parent445f2721f92bae4a9ae86e13f14775e924dc7f84 (diff)
downloadopenembedded-core-2cf6e7cf81c0b864b5d51be60094a6eb3e584383.tar.gz
fotowall: Add #include ui_wizard.h to ExportWizard.cpp
App/ExportWizard.cpp depends on wizard.h which depends on ui_wizard. The last one should be already generated before compiling ExportWizard.cpp. [YOCTO #2297] Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'meta/recipes-qt/qt-apps')
-rw-r--r--meta/recipes-qt/qt-apps/fotowall/ExportWizard-depends-on-ui_wizard.patch18
-rw-r--r--meta/recipes-qt/qt-apps/fotowall_0.9.bb6
2 files changed, 22 insertions, 2 deletions
diff --git a/meta/recipes-qt/qt-apps/fotowall/ExportWizard-depends-on-ui_wizard.patch b/meta/recipes-qt/qt-apps/fotowall/ExportWizard-depends-on-ui_wizard.patch
new file mode 100644
index 0000000000..d8b2b2347b
--- /dev/null
+++ b/meta/recipes-qt/qt-apps/fotowall/ExportWizard-depends-on-ui_wizard.patch
@@ -0,0 +1,18 @@
+App/ExportWizard.cpp depends on wizard.h which depends on ui_wizard. The last one
+should be already generated before compiling ExportWizard.cpp.
+
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+Upstream-Status: Pending
+
+Index: Fotowall-0.9/App/ExportWizard.cpp
+===================================================================
+--- Fotowall-0.9.orig/App/ExportWizard.cpp 2009-11-30 13:21:31.000000000 +0200
++++ Fotowall-0.9/App/ExportWizard.cpp 2012-05-10 17:12:06.765230830 +0300
+@@ -23,6 +23,7 @@
+ #include "imageloaderqt.h"
+ #include "posterazorcore.h"
+ #include "wizard.h"
++#include "ui_wizard.h"
+
+ #include <QDesktopServices>
+ #include <QDesktopWidget>
diff --git a/meta/recipes-qt/qt-apps/fotowall_0.9.bb b/meta/recipes-qt/qt-apps/fotowall_0.9.bb
index 52dd727351..3cb79a31a2 100644
--- a/meta/recipes-qt/qt-apps/fotowall_0.9.bb
+++ b/meta/recipes-qt/qt-apps/fotowall_0.9.bb
@@ -7,12 +7,14 @@ LIC_FILES_CHKSUM = "file://GPL_V2;md5=79808397c3355f163c012616125c9e26 \
file://main.cpp;beginline=6;endline=11;md5=b569acc2bf8974a3082b58fc53b9d8dc"
SECTION = "x11/apps"
-PR = "r2"
+PR = "r3"
DEPENDS = "qt4-x11-free"
RRECOMMENDS_${PN} += "qt4-plugin-imageformat-gif qt4-plugin-imageformat-jpeg qt4-plugin-imageformat-tiff"
-SRC_URI = "http://qt-apps.org/CONTENT/content-files/71316-Fotowall-0.9.tar.bz2"
+SRC_URI = "http://qt-apps.org/CONTENT/content-files/71316-Fotowall-0.9.tar.bz2 \
+ file://ExportWizard-depends-on-ui_wizard.patch \
+ "
SRC_URI[md5sum] = "142ef697332e0777c6d22c5bc96cc438"
SRC_URI[sha256sum] = "e4d0c005d2cb1d7c09438bfc3098eadebc08946e4fbc0655b7fc8b046de3810d"