aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt4/qt-4.7.3.inc
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-09-15 11:47:16 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-04 11:34:22 +0100
commit8d5a5d78f9e83c64ebddcecd7c4fd89cc1264163 (patch)
tree12c94221bc08b3c6ee5facef8d1e5b1e565fa88c /meta/recipes-qt/qt4/qt-4.7.3.inc
parent97446651cd5128ca7a549df677c920e2463c46f9 (diff)
downloadopenembedded-core-8d5a5d78f9e83c64ebddcecd7c4fd89cc1264163.tar.gz
qt4: Fix translation support
The translation support was disable in build. The fix-translation.patch was imported from OpenEmbedded to fix a linking issue in phonon translation support. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta/recipes-qt/qt4/qt-4.7.3.inc')
-rw-r--r--meta/recipes-qt/qt4/qt-4.7.3.inc9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta/recipes-qt/qt4/qt-4.7.3.inc b/meta/recipes-qt/qt4/qt-4.7.3.inc
index a5b8b05bff..16c7b08908 100644
--- a/meta/recipes-qt/qt4/qt-4.7.3.inc
+++ b/meta/recipes-qt/qt4/qt-4.7.3.inc
@@ -13,6 +13,7 @@ SRC_URI = "http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-${PV}.
file://0009-support-2bpp.patch \
file://0001-Added-Openembedded-crossarch-option.patch \
file://blacklist-diginotar-certs.diff \
+ file://fix-translations.patch \
file://g++.conf \
file://linux.conf \
"
@@ -26,7 +27,9 @@ FILES_${QT_BASE_NAME}-tools += "${bindir}/qml"
do_configure_prepend() {
for pro in $(find ${S} -name "*.pro") ; do
- sed -i 's:$$QT_BUILD_TREE/bin/lrelease:${OE_QMAKE_LRELEASE}:g' $pro
+ sed -i \
+ -e 's:$$QT_BUILD_TREE/bin/lrelease:${OE_QMAKE_LRELEASE}:g' \
+ -e 's:qtPrepareTool(LRELEASE, lrelease):LRELEASE = ${OE_QMAKE_LRELEASE}:g' $pro
done
sed -i s:SEDME:${S}: ${WORKDIR}/linux.conf
@@ -38,10 +41,6 @@ do_configure_prepend() {
${S}/configure
}
-do_configure_append() {
- sed -e '/QMAKE_TARGET /d' -e '/TARGET /d' -i ${S}/translations/Makefile
-}
-
QT_GLFLAGS ?= ""
QT_CONFIG_FLAGS += " -xmlpatterns -no-rpath -qt3support -reduce-relocations -silent ${QT_GLFLAGS}"