aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-panel-2
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-11-18 00:49:05 +0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:28 -0800
commita79165c616a3e60a0e8e127394fda53f467455b0 (patch)
treec12f0b20120299bc1f7c7b0e77e460058a1a32fb /meta/recipes-sato/matchbox-panel-2
parent0a751b7dc273140968f7a1784382fe1f0932be62 (diff)
downloadopenembedded-core-a79165c616a3e60a0e8e127394fda53f467455b0.tar.gz
matchbox-panel: Change function name "sync" to avoid conflict
/usr/includes/unistd.h also has a function named sync(). Change sync() in matchbox-panel-2 to sync_applet(). Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-sato/matchbox-panel-2')
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2/fix_sync_funcname.patch34
-rw-r--r--meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb5
2 files changed, 37 insertions, 2 deletions
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2/fix_sync_funcname.patch b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2/fix_sync_funcname.patch
new file mode 100644
index 0000000000..25d08eda8b
--- /dev/null
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2/fix_sync_funcname.patch
@@ -0,0 +1,34 @@
+Rename function sync to sync_applet to avoid conflict.
+
+Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
+
+diff -ruN matchbox-panel-2-orig/applets/showdesktop/showdesktop.c matchbox-panel-2/applets/showdesktop/showdesktop.c
+--- matchbox-panel-2-orig/applets/showdesktop/showdesktop.c 2010-11-17 20:59:46.000000000 +0800
++++ matchbox-panel-2/applets/showdesktop/showdesktop.c 2010-11-17 21:00:11.000000000 +0800
+@@ -57,7 +57,7 @@
+
+ /* Sync @applet with the _NET_SHOWING_DESKTOP root window property */
+ static void
+-sync (ShowDesktopApplet *applet)
++sync_applet (ShowDesktopApplet *applet)
+ {
+ GdkDisplay *display;
+ Atom type;
+@@ -103,7 +103,7 @@
+ if (xev->type == PropertyNotify) {
+ if (xev->xproperty.atom == applet->atom) {
+ /* _NET_SHOWING_DESKTOP changed */
+- sync (applet);
++ sync_applet (applet);
+ }
+ }
+
+@@ -145,7 +145,7 @@
+ applet);
+
+ /* Sync */
+- sync (applet);
++ sync_applet (applet);
+ }
+
+ /* Button clicked */
diff --git a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb
index 45998633f4..f4ebcfb5e5 100644
--- a/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb
+++ b/meta/recipes-sato/matchbox-panel-2/matchbox-panel-2_svn.bb
@@ -13,14 +13,15 @@ DEPENDS += " ${@base_contains("MACHINE_FEATURES", "acpi", "libacpi", "",d)}"
DEPENDS += " ${@base_contains("MACHINE_FEATURES", "apm", "apmd", "",d)}"
PV = "0.0+svnr${SRCREV}"
-PR = "r5"
+PR = "r6"
RPROVIDES_${PN} = "matchbox-panel"
RREPLACES_${PN} = "matchbox-panel"
RCONFLICTS_${PN} = "matchbox-panel"
SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN};proto=http \
- file://startup_fix.diff;patch=1"
+ file://startup_fix.diff;patch=1 \
+ file://fix_sync_funcname.patch"
EXTRA_OECONF = "--enable-startup-notification --enable-dbus"
EXTRA_OECONF += " ${@base_contains("MACHINE_FEATURES", "acpi", "--with-battery=acpi", "",d)}"